[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: HelpViewer 0.3 : error while linking

From: Patrick Cardona
Subject: Re: HelpViewer 0.3 : error while linking
Date: Mon, 06 Jul 2020 14:50:05 +0200
User-agent: GNUMail (Version 1.3.0)

Hi Riccardo,
Hi All

On 2020-06-29 23:26:16 +0200 Riccardo Mottola <riccardo.mottola@libero.it> wrote:

Hi Patrick,

thanks for your interest in GAP application, first thing.
I am revived my Raspberry PI 1 to "jessie" (still unsure if I can update it further, but i had to reinstall, the past attempt to update it bricked it). Then I also have RPI3 and RPI4 to test with GNUstep. You just gave me the impulse to buy another one and keep it as light computer at my parents! Seems to work fine, but e.g. I noticed that for some reason GNUMail is not 100% reliable like on x86, needs to be tested further.

I am curious : what are these things not reliable within GNUMail ?

You are not forced to build & install everything. Personally I don't use those top-level makefiles either, I install and upgrade the specific apps.

It was only for testing purpose, but I also need less apps for a dayly use... ;-)

Have seen that... I don't know, all this linker stuff is a mess. I did try
with gcc and its runtime and it worked some weeks ago. So many variants,
Well, I wanted to use clang because many advices at the list said it would be better to learn Objectice-C and create new apps with that modern compiler. But I feel that with my RPI 32 bit, and the tests you did, I should revert to the 'old' GCC and make it all again,

you really should be able to use both and both should work in my opinion and then decide your won taste what to use. If only Cythiune is giving you erros, maybe somebody has a hint on how to fix linking!

Well, I made a fresh install of the Pi OS (i.e. Debian Buster, 10.4 on my RPI 3B+) from a new SD card to avoid many upgrade issues (my previous attempt was an upgrade from Stretch to Buster) and to be sure to start from a clean basis.

Then I achieved to make all the GNUstep core and GWorkspace, Gorm, Project Center, SystemPreferences, Recycler... with clang 7 and GNUstep 1.9 runtime, behalf of the Patryck Laurent's script.

I could then make some apps, run those and retrieve my data from my previous backup : these are AddressesManager, Affiche, DictionaryReader, Gemas, GNUMail, Graphos, Grr, GSPdf, ImageViewer, Ink, SimpleAgenda, Terminal and Zipper.

I applied with success the Heritage theme, tested also removable device mounting within GWorkspace. All worked as expected.

But I was stuck again at the error I already described while making Cynthiune app, precisely while making the ALSA bundle : undefined version of the __malloc_initialize_hook symbol.

After some new search on the Web, I found this clue from

malloc: Use compat_symbol_reference in libmcheck [BZ #22050]

Since glibc 2.24, __malloc_initialize_hook is a compat symbol.  As a
    result, the link editor does not export a definition of
__malloc_initialize_hook from the main program, so that it no longer interposes the variable definition in libc.so. Specifying the symbol
    version restores the exported symbol.

If I understand it well, I shoud supply a version number for that symbol at linking time, but I don't kwow:
1) How to do it.
2) And not the least, what should be the appropriate version... ?

Life is so gray without music...  If someone could help...

Il also was not able to make Pikopixel this time, but I must investigate and try again, because I remember I could do it previously...



Patrick C.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]