[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: FreeBSD ports for GDL2 and GSWeb

From: Edwin Ancaer
Subject: Re: FreeBSD ports for GDL2 and GSWeb
Date: Thu, 30 May 2019 06:58:50 +0200

Hello guys,

one last request before I return to gardening: it seems that the above error only occurs with the poudriere port that I try to create. I can build all other gnustep ports without problems.

I attached the Makefile, pkg-descr, pkg-plist and distinfo for the port. If someone could have a look if the error occurs at their side also, it might just be a local problem.

Thans for the help you all provided,

Op wo 29 mei 2019 om 10:22 schreef Edwin Ancaer <address@hidden>:
Reading Davids answer, I realize I did not explain well what was the problem. The error occurred during the at the execution of the poudriere testport command, giving a following logfile:

=>> Recording filesystem state for prebuild... done
=======================<phase: configure      >============================
===>   renaissanc- depends on executable: gmake - found
===>   renaissanc- depends on file: /usr/local/bin/ld.gold - found
===>   renaissanc- depends on shared library: libgnustep-base.so - found (/usr/local/GNUstep/System/Library/Libraries/libgnustep-base.so)
===>   renaissanc- depends on shared library: libgnustep-gui.so - found (/usr/local/GNUstep/System/Library/Libraries/libgnustep-gui.so)
===>  Configuring for renaissanc-
=======================<phase: build          >============================
===>  Building for renaissanc-
gmake[1]: Entering directory '/wrkdirs/usr/ports/devel/renaissance/work/libs-renaissance-13bd630'
GNUmakefile:30: Unable to obtain GNUSTEP_MAKEFILES setting from gnustep-config!
GNUmakefile:31: Perhaps gnustep-make is not properly installed,
GNUmakefile:32: so gnustep-config is not in your PATH.
GNUmakefile:34: Your PATH is currently /wrkdirs/usr/ports/devel/renaissance/work/.bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/nonexistent/bin
GNUmakefile:40: *** You need to set GNUSTEP_MAKEFILES before compiling!.  Stop.
gmake[1]: Leaving directory '/wrkdirs/usr/ports/devel/renaissance/work/libs-renaissance-13bd630'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

That was solved by adding build to the line:  USE_GNUSTEP=   base gui build.

Now the next problem has occurred:

====> Running Q/A tests (stage-qa)
Warning: 'GNUstep/System/Library/Libraries/libRenaissance.so.0.9.0' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'GNUstep/System/Applications/GSMarkupLocalizableStrings.app/GSMarkupLocalizableStrings' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
Warning: 'GNUstep/System/Applications/GSMarkupBrowser.app/GSMarkupBrowser' is not stripped consider trying INSTALL_TARGET=install-strip or using ${STRIP_CMD}
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
===> Checking for items in pkg-plist which are not in STAGEDIR
===> No pkg-plist issues found (check-plist)
=>> Checking for staging violations... done
=======================<phase: package        >============================
===>  Building package for renaissance-
Child process pid=66023 terminated abnormally: Bus error
*** Error code 1

make: stopped in /usr/ports/devel/renaissance
build of devel/renaissance | renaissance- ended at Wed May 29 09:39:04 CEST 2019
build time: 00:01:55
!!! build failure encountered !!!
[00:02:04] Error: Build failed in phase: package
[00:02:04] Cleaning up
[00:02:04] Unmounting file systems

If you're still not bored to death by this endless series of problems, any clues on how to solve this are appreciated.

Kind regards,

Op ma 27 mei 2019 om 19:06 schreef David Chisnall <address@hidden>:
On 27 May 2019, at 12:07, Edwin Ancaer <address@hidden> wrote:
> The one haunting me now is the fact that I have to run the poudriere command  to test my port for renaissance as root  and that for root, the GNUStep environment is not defined.

You have to run poudriere as root, but then it will source the relevant gnustep files in the jail that it uses for building if the port is marked as USES = gnustep.  You should then end up with a package repo somewhere inside /usr/local/poudriere.  The best thing to do is create a local config file in /usr/local/etc/pkg/repos/ pointing to that and install the package from there for testing.  You don’t have to do anything inside the poudriere-created jail other than check that things build, you can test on any system you like (including the host).


Attachment: distinfo
Description: Binary data

Attachment: pkg-descr
Description: Binary data

Attachment: Makefile
Description: Binary data

Attachment: pkg-plist
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]