discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with GNUtls 3.6.7


From: Germán Arias
Subject: Re: Problem with GNUtls 3.6.7
Date: Tue, 28 May 2019 01:27:41 -0600
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.7.0

Well, I remove completely GNUstep. Run "make clean" then configure and
make but still the same problem. I will report this problem. This is not
the first time I have a problem with this distro. Initially I was not
able to compile gnustep due to a internal compiler error. This was
solved after an update of all gcc packages. I switch to PCLinuxOS
because don't use systemd, I had many problems with systemd on OpenSUSE.
Regards.

Germán

On 27/05/19 04:24, Richard Frith-Macdonald wrote:

On 27 May 2019, at 11:11, Fred Kiefer <address@hidden> wrote:

I have GNUTLS 3.6.7 on my machine as well, but never had an issue with it. Are 
you sure that you did reconfigure and recompile GNUstep base from scratch? 
Perhaps give it another try and report back. (Remember to use „make clean“ 
first!)

Hope this helps,
Fred

Am 27.05.2019 um 02:00 schrieb Germán Arias <address@hidden>:

Some days ago my system (PCLinuxOS) update the GNUtls library to version
3.6.7. And now the gnustep apps don't work. So, I try to recompile all,
but now I get the error:

Linking tool autogsdoc ...
/usr/bin/ld: ../Source/./obj/libgnustep-base.so: undefined reference to
address@hidden'

Is this a problem with the gnutls library? Or gnustep is not compatible
with this version of gnutls?

I'm going to guess that where the loader is complaining about a missing symbol 
containing GNUTLS_3_4 it's that the code was linked with version 3.4.? of the 
library and what is now installed is 3.6.7

That would mean that things have *not* been recompiled/rebuilt.  Since it's the 
base library that's linked with gnutles (unless other stuff is linked with it), 
My guess is that what's required in gnustep-base is a
make clean
make install
sequence.



_______________________________________________
Discuss-gnustep mailing list
address@hidden
https://lists.gnu.org/mailman/listinfo/discuss-gnustep



reply via email to

[Prev in Thread] Current Thread [Next in Thread]