discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnuconfig and runtime 1.9/ARC issue


From: Andreas Fink
Subject: Re: gnuconfig and runtime 1.9/ARC issue
Date: Mon, 6 May 2019 13:34:07 +0200

you can also do

export RUNTIME_VERSION=2.0
before you configure/make/install gnustep-make & base and your code.

That overrides whats in libray-combo.make

I usually edit libray-combo.make before I make packages for it


> On 6 May 2019, at 10:14, Frederik Seiffert <address@hidden> wrote:
> 
> Hi Johannes,
> 
>> So somehow the runtime version is still written twice - once using the
>> wrong version (1.8)
> 
> I ran into the same issue and was able to fix it by providing a user config 
> file containing "RUNTIME_VERSION=gnustep-1.9" to GNUstep make using 
> --with-user-config-file=<file>.
> 
> This is caused by library-combo.make always adding 1.8 if RUNTIME_VERSION is 
> unspecified using the ng runtime, which seems like something that should be 
> revisited (esp. now that newer runtime versions are recommended):
> https://github.com/gnustep/tools-make/blob/14a1d33/library-combo.make#L46-L48
> 
> Hope that helps!
> 
> Frederik
> 
> 
> _______________________________________________
> Discuss-gnustep mailing list
> address@hidden
> https://lists.gnu.org/mailman/listinfo/discuss-gnustep





reply via email to

[Prev in Thread] Current Thread [Next in Thread]