discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep on a fresh Debian (S1-E3)


From: Stefan Bidigaray
Subject: Re: GNUstep on a fresh Debian (S1-E3)
Date: Fri, 4 Mar 2016 16:28:04 -0500


On Mar 4, 2016 11:03 AM, "Richard Frith-Macdonald" <address@hidden> wrote:
>
>
> > On 4 Mar 2016, at 15:57, Richard Frith-Macdonald <address@hidden> wrote:
> >
> >
> >> On 3 Mar 2016, at 15:00, Tristan Bellogi <address@hidden> wrote:
> >>
> >> # The 2 failed tests
> >> base/NSNumberFormatter/basic10_4.m:
> >> Failed test:         basic10_4.m:145 ... negativeFormat used for -ve number
> >
> > This one I can't reproduce, but it sounds like a very minor bug, unlikely to be a problem in most software.  It might help to know what the actual format produced was (should be in tests.log), what version of icu is on your system, and what your locale is set to, since the icu library and the locale are the things likely to influence number formatting.  It's possible that the testcase is wrong.
>
> What I mean is, while we want to get any bug fixed (and if you can provide more info, it might help with that; if it means someone can reproduce it), I don't think this is one you need to actually worry about.

I've ran into these sort of issues a bunch of times with the formatting code. The problem is that ICU keeps changing/refining the output of its formatters, so it is very hard to run unit tests on them.

It's strange that it's happening with a number formatter, though.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]