discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error compiling libobjc2


From: David Chisnall
Subject: Re: Error compiling libobjc2
Date: Thu, 28 Feb 2013 08:18:08 +0000

Hi Abhi,

On 28 Feb 2013, at 01:56, Abhi Beckert <address@hidden> wrote:

> Does anyone know what I'm doing wrong?

You're not doing anything wrong, but I'm guessing that you're using a trunk 
build of LLVM?  A couple of the LLVM APIs have changed in 3.3 and I haven't got 
around to updating the optimisations.  If you run ccmake . then it should give 
you a list of options.  One of them is LLVM_OPTS, toggle this to no (or pass 
-DLLVM_OPTS=NO to the cmake command line) to disable them.

I'll hopefully have time to update the code tomorrow.  I'll also make it 
disable building the LLVM optimisations by default for versions of LLVM that I 
haven't tested with.

Sorry for the inconvenience,

David

-- Sent from my Difference Engine






reply via email to

[Prev in Thread] Current Thread [Next in Thread]