discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building fun again


From: Ivan Vučica
Subject: Re: Building fun again
Date: Sat, 31 Mar 2012 23:15:27 +0200

Feel free to cc the mailing list, they may be able to help you far better than I can with some of these problems. :-)

On Sat, Mar 31, 2012 at 22:50, Dr. James R. Pannozzi D.O.M. LAc. <address@hidden> wrote:
Ya is  good, these problems were resolved.

I have details on what I did , but basically just your install script
and then I make sure that PATH was set to point to the bin sub folder
of Release and that the GNUstep.sh was sourced properly.   Also, as
your install script shows, the compilation of gnumake is a little
tricky, I think must compile it twice.   Then just go into sample apps
like Gomoku and start compiling.  Some apps missing lrand and srand, I
don't know where to get these but can just write my own I guess.
Thought the compiler had them but guess not.

Main problems are:  on  windows xp, for example, I can compile and run
Gomoku no problem.  On Ubuntu,  no window opens when I click on new
game.  Can use gnu debug no problem, works fine so when I have time
will figure out what the holdup is.

On the Radon transform app, compiles OK but nothing happens when I
start it.  No docs on how to start it.  Will have to run that through
debugger too.  Scanning applications are my main interest why I found
GNUstep.  What with the Affine transform and other graphics stuff,
GNUStep has exactly what I need without spending $$$ for a Mac.

All  systems -  stuff missing or does not work right for GWorkspace.
Files will not open and other odd stuff happening.

Fedora Core 14 and 16, cannot get good install of GNUStep. something
like your Ubuntu install script not working and compiler gets messed
up -> get message something like "this is not the same compiler
options you used to compile gnumake", when I try to compile
gnustep-back or gnustep-gui.

Now I try BSD (PC-BSD) but instructions for install  GNUSTEP on it
seem old.  I try version 9.0 (Isotope) and lot of BSD bugs, even in
the install, hangs for long time finally install.  Then system locks
up often when leave it alone for a few minutes.  This was supposed to
be the STABLE release version.  No wireless card working so I use a
shared internet connection from my laptop.  Next tried version PC-BSD
9.1 with the new installer, that's the box I'm on now.  Operating
system now works GOOD.  This is on an ESystems box with 4 gig RAM,
500Gig disk drive,  Intel dual core processor.

Will exercise the encrypted zfs file system a little, install some
apps, then see how to install GNUSTEP on it.   Don't know if I'm
supposed to install from the BSD ports, or use AppCafe or use an .sh
but I do see, right after the initial install of the operating system,
a folder called GNUstep, so they have tried to install something there
automatically.   Contents of this folder are two other folders:
"Defaults" and "Library" but there's next to nothing in them other
than something called Windowmaker with a .jpg in it and Defaults
faulder just has
Windowmaker.txt and WMRootMaker.txt in it.

Thanks for that Ubuntu install script, that really helped a lot -
never used CLANG before but I have no problems with it, so far pretty
good!

Thanks Again,
J.

On 3/31/12, Ivan Vučica <address@hidden> wrote:
> On Tue, Jan 17, 2012 at 14:29, Citizen Jimserac <address@hidden> wrote:
>
>> MANY thanks!   So.... clang instead of gcc??   Well this IS a
>> surprise, for years I've relied on gcc whenever compiling something on
>> linux (or ming gcc on windows).
>>
>
> clang is a nicer compiler for Objective-C.
>
>
>> Yes, I see when compiling that "make" does nothing when a GNUMakefile
>> is present...
>> for example,
>> GNUmakefile:25: /common.make: No such file or directory
>> GNUmakefile:35: /aggregate.make: No such file or directory when trying
>> to compile gnustep-gui examples.
>>
>
> I'm not sure what might be causing this, but it sounds like GNUstep.sh was
> not properly sourced using:
>
> . /path/to/GNUstep.sh
>
>
>>
>> Could you describe in more detail your post install things such as...
>>
>> "Post-compile, I also added
>> ~/llvm/Release+Asserts/bin into PATH, and I sourced GNUstep.sh to make
>> compiling easier. "
>>
>>
> In .bash_profile, I added approximately the following lines:
>
> PATH=~/llvm/Release+Asserts/bin:$PATH
> . /path/to/GNUstep.sh
>
> --
> Ivan Vučica - address@hidden
>



--
Ivan Vučica - address@hidden



reply via email to

[Prev in Thread] Current Thread [Next in Thread]