discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: problem porting sogo to use gnustep-make 2


From: Sebastian Reitenbach
Subject: RE: problem porting sogo to use gnustep-make 2
Date: Mon, 21 Jan 2008 07:36:16 +0100

Hi,

address@hidden wrote: 
> 
> > I have got sope and sogo working now with only touching the GNUmakefiles 
and 
> > the ./configure scripts. I create a central config.make file where I 
define 
> > the main path variables, depending on either installation into GNUstep 
or 
> > FHS filesystem layout. So changing these is already ten times easier as 
it 
> > was before where these paths were set in many places.
> 
> I can see the reason for this - but are you sure this is the easiest 
approach ? ;-)
> 
> It might be easier to leave the existing FHS hacks in place without 
changes (so
> you don't break the existing packaging etc), and make the small changes to 
the
> GNUmakefiles to have them work with gnustep-make v2 (this shouldn't break
> anything - the changes should be backwards-compatible with gnustep-make 
v1). ;-)
> 
> Then you only need to update the ObjC code to look up things in the right 
place
> when running on gnustep-base/gnustep-make v2 (my ObjC patches should do 
most
> of it) and it should all work (and wouldn't break anything unless 
gnustep-base
> is being used, in which case it should work more generally). :-)
> 
> Later on, once the gnustep-make v2 support is all working, the FHS hacks 
could
> be removed completely in favour of the gnustep-make v2 FHS support. :-)
> 
> Anyway, it looks like you're doing it differently - might even be a better 
> solution - let us know how it goes. :-)

I merged your patches with mine. compilation against gnustep-base 1.13.
failed at NGResourceLocator.m because GSWebApplicationsDirectory and friends
are not defined in NSPathUtilities.h, so at least gnustep-base 1.14 would be 
needed. This would also break compatibility with at least libFoundation, 
also an #if GNUSTEP_BASE_LIBRARY was missing around the method 
standardSearchPathsForGNUstepPath, so that compilation will not break when 
compiling against other foundations libraries.
I never tried to use gnustep-base >= 1.14 with gnustep-make < 2, so I don't 
know if this would work at all. Therefore I think there is no reason to keep 
the gnustep-make 1 compatibility in the sope makefiles.

here is what I have done:
http://svn.opengroupware.org/viewcvs/branches/?root=SOPE

It is not yet installing into GNUSTEP_WEB_APPS, still installing into 
GNUSTEP_LIBRARY. I tried to install into GNUSTEP_WEB_APPS, but that does not 
seem to work yet.

kind regards
Sebastian






reply via email to

[Prev in Thread] Current Thread [Next in Thread]