discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Update GNUstep on Debian to more recent version?


From: Yavor Doganov
Subject: Re: Update GNUstep on Debian to more recent version?
Date: Wed, 19 Dec 2007 11:50:59 +0000 (UTC)
User-agent: Pan/0.132 (Waxed in Black)

В Wed, 19 Dec 2007 03:01:30 -0800, address@hidden написа:

>> Please file a bug report (`reportbug gorm.app' or `M-x debian-bug RET p
>> RET gorm.app RET' if you use Emacs).  I'll try to reproduce this on a
>> stable box.

Hmm, there are no bugs filed against the debian package gorm.app.  
Perhaps you meant http://savannah.gnu.org/bugs/?21845?

> It appears to be a quite sophisticated process which contributes to a
> high level of stability

Yes, it is.  Debian stable releases are stable as a rock, at least from 
my experience.

> - although it might be a little slow if one
> wants to use stable versions only (1,5 years from stable GNUstep on Etch
> to the next one...).

For free software developers, running stable is not suitable in most 
cases, yes -- especially if you want to use new features available in the 
new versions of the libraries, tools, modern compilers, etc.  There are 
roughly two solutions: 1) use `testing' which is regularly updated but 
doesn't break that often like unstable -- that's what I do at work; 2) 
rebuild the whole GNUstep pile yourself and remember to rebuild it every 
time there is a SONAME change (which unfortunately means every new major 
release).

> Many thanks for this description.

You're welcome.





reply via email to

[Prev in Thread] Current Thread [Next in Thread]