discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compile problem on OPENSTEP 4.2


From: moi
Subject: Re: compile problem on OPENSTEP 4.2
Date: Mon, 15 Oct 2007 23:11:46 +0200

Hi,
Le 13 oct. 07 à 22:36, Lars Sonchocky-Helldorf a écrit :

Hi list,

I am currently in the process of porting Resound 3.0 <http:// www.cs.gmu.edu/~sean/projects/next/Resound/> from Rhapsody to OPENSTEP 4.2 (and to GNUstep later on so I hope my question is not regarded as off-topic).

When I try to invoke a build in Project Builder I get the following error messages:

== Making Resound for i386 ==
Pre-build setup...
...skipping FileType.subproj
Building...
...skipping FileType.subproj
/bin/cc -arch i386 -Wmost -g -fno-common -I/Users/lars/Developer/ Resound3.0-PI-bs/Source/ProjectHeaders -I/Users/lars/Developer/ Resound3.0-PI-bs/Source/Resound.app/PrivateHeaders -I/Users/lars/ Developer/Resound3.0-PI-bs/Source/Resound.app/Headers -I/Users/lars/ Developer/Resound3.0-PI-bs/Source/derived_src -I. -arch i386 - pipe -ObjC -c -o /Users/lars/Developer/Resound3.0-PI- bs/Source/obj-i386-opt/ModuleSound.o ModuleSound.m ModuleSound.h:30: warning: could not use precompiled header '/ NextLibrary/Frameworks/SoundKit.framework/Headers/SoundKit.p', because:
ModuleSound.h:30: warning: header 'streams/streams.h' overridden,
ModuleSound.h:30: warning: ./streams/streams.h vs. /NextLibrary/ Frameworks/System.framework/Headers/streams/streams.h (within the precomp) /NextLibrary/Frameworks/System.framework/Headers/objc/HashTable.h: 13: warning: could not use precompiled header '/NextLibrary/ Frameworks/System.framework/Headers/objc/Object.p', because: /NextLibrary/Frameworks/System.framework/Headers/objc/HashTable.h: 13: warning: header 'streams/streams.h' overridden, /NextLibrary/Frameworks/System.framework/Headers/objc/HashTable.h: 13: warning: ./streams/streams.h vs. /NextLibrary/Frameworks/ System.framework/Headers/streams/streams.h (within the precomp) In file included from /NextLibrary/Frameworks/SoundKit.framework/ Headers/convertsound.h:9,
                 from ModuleSound.m:33:
/NextLibrary/Frameworks/SoundKit.framework/Headers/sounderror.h:9: conflicting types for `SND_ERR_NONE' /NextDeveloper/Headers/sound/sounderror.h:9: previous declaration of `SND_ERR_NONE' /NextLibrary/Frameworks/SoundKit.framework/Headers/sounderror.h:10: conflicting types for `SND_ERR_NOT_SOUND' /NextDeveloper/Headers/sound/sounderror.h:10: previous declaration of `SND_ERR_NOT_SOUND'

I don't know what I could do about this, e.g. how to keep the compiler from using both /NextLibrary/Frameworks/SoundKit.framework/ Headers/ and /NextDeveloper/Headers/

maybe someone with sufficient OPENSTEP experience knows this situation and can tell me how to fix it.

I have attached the complete console output of this build attempt, a screenshot of the PB Window and the PB.project of Resound (if this can provide a hint)


regards,

        Lars



<PB.project>

<resound-build-failure.tiff>

<resound-build-failure.txt.rtf>
_______________________________________________
Discuss-gnustep mailing list
address@hidden
http://lists.gnu.org/mailman/listinfo/discuss-gnustep

In the build option, is there a way to choose wich header to include, like in PB3.3 ?

Could you please send the resound3 archive because I cant download it on the site, thanks.

Charles



reply via email to

[Prev in Thread] Current Thread [Next in Thread]