[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Building GNUstep/Etoile on Solaris

From: Andreas Höschler
Subject: Building GNUstep/Etoile on Solaris
Date: Fri, 23 Feb 2007 13:35:23 +0100

Hi all,

I just got the latest sources of GNUstep and Etoile from svn and tried to build them on Solaris 10 SPARC.

I managed to build GNUstep but got a couple of problems with Etoile. If I build any part with just make I get this error.

Making all for library CollectionKit...
make[2]: Nothing to be done for `internal-library-all'.
make[1]: Leaving directory `/usr/share/src/etoile/Etoile/Frameworks/CollectionKit/Source'
/bin/sh: syntax error at line 1: `end of file' unexpected
make: *** [after-all] Error 2

The build goes through if I use "make messages=yes" instead. Weird! I got a bunch of problems solved by inserting includes... but I am stuck atthe following:

gcc PortableUContext_asm.S -c -o obj/PortableUContext_asm.o
/usr/ccs/bin/as: "/var/tmp//ccpvBU4f.s", line 6: error: unknown "%"-symbol /usr/ccs/bin/as: "/var/tmp//ccpvBU4f.s", line 6: error: quoted-string operand required
/usr/ccs/bin/as: "/var/tmp//ccpvBU4f.s", line 6: error: statement syntax
make[4]: *** [obj/PortableUContext_asm.o] Error 1
make[3]: *** [coroutine.all.subproject.variables] Error 2
make[3]: Leaving directory `/usr/share/src/etoile/Etoile/Languages/Io/coroutine'
make[2]: *** [ioobjc.all.tool.variables] Error 2
make[2]: Leaving directory `/usr/share/src/etoile/Etoile/Languages/Io'
make[1]: *** [internal-all] Error 2
make[1]: Leaving directory `/usr/share/src/etoile/Etoile/Languages'
make: *** [internal-all] Error 2

The stuff in PortableUContext_asm.S does not seem to be portable! Any idea?




reply via email to

[Prev in Thread] Current Thread [Next in Thread]