discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep-back does not build Cairo backend without glx and wgl


From: Stefan Bidigaray
Subject: Re: GNUstep-back does not build Cairo backend without glx and wgl
Date: Wed, 14 Feb 2007 12:01:58 -0500

On 2/14/07, Richard Frith-Macdonald <address@hidden> wrote:

On 14 Feb 2007, at 15:07, Stefan Bidigaray wrote:

> It should work this time!
>

Ah, I see it's asking for glx *or*, wgl, not glx *and* wgl.

It looks like the check is trying to ensure that we have a glitz
backend.
Does building with glitz make sense if we don't have a backend?

Assuming that we need to have a backend, I;m still not sure the test ...
probably it should be testing that  if we have glitz enabled we also
have either
1. x11 and glx
or
2. win32 and wgl
 
So pretty much glitz needs glx or wgl?  I guess this was a problem with the previous check then, because like I said this is the first time I'm seeing these errors.  I wasn't even aware of glitz's requirements (shows how much I know).  I'll grab glx next time I build, see how that comes out.
 
Thanks

 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]