discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

LD_LIBRARY_PATH not set when doing "sudo make install"


From: Pablo Di Noto
Subject: LD_LIBRARY_PATH not set when doing "sudo make install"
Date: Thu, 07 Apr 2005 13:02:30 -0300
User-agent: Debian Thunderbird 1.0.2 (X11/20050331)


I am installing a fresh GNUstep copy on Debian sid. Startup 0.10.0
 worked ok and I got GNUstep working.

Compiled and installed Gorm without problem. Then compiled ProjectCenter and got this:

Making all for app ProjectCenter... Creating
ProjectCenter.app/Resources/ProjectCenter.desktop... /bin/sh:
pl2link: command not found make[1]: ***
[ProjectCenter.app/Resources/ProjectCenter.desktop] Error 127 make: *** [ProjectCenter.all.app.variables] Error 2

which is the first time I notice. What ple2link is for? Where is supposed to come from?

pl2link is provided by gnustep-base and located in /usr/GNUstep/System/Tools/pl2link

And according to the source: This tool produces a desktop link file
for KDE and Gnome out of a GNUstep property list.

Are all variables set allright? Try the following: .
/usr/GNUstep/System/Library/Makefiles/GNUstep-reset.sh .
/usr/GNUstep/System/Library/Makefiles/GNUstep.sh And rebuild

Well, doing a reset did not help. I was compiling under my user and
installing using sudo. I tried the whole process under root and it works.

I collected environment variables before and after sourcing GNUstep.sh
for both user and root and diff them to see why under a normal user and
sudo it does not find pl2link. I saw no difference.

But now I see that under sudo the LD_LIBRARY_PATH is not set. Not sure
whose fault it is (may be it is just a security feature), but I am
pretty sure I installed PC and other apps this way before.

address@hidden:~/Development/GNUstep/dev-apps/ProjectCenter$ sudo
/usr/GNUstep/System/Tools/pl2link /usr/GNUstep/System/Tools/pl2link:
error while loading shared libraries: libgnustep-base.so.1.10: cannot
open shared object file: No such file or directory

So, I will try to see where the problem lies.
By now, I just made "make install" as root.

Thanks!
///Pablo





reply via email to

[Prev in Thread] Current Thread [Next in Thread]