So I'd like to change gnustep-make so that if you provide a file called
xxx_Info.plist (please note the underscore to differentiate it from the
xxxInfo.plist which is used at the moment), it will skip the process
entirely and just use that. We'll have a makefile variable which lets you
change the name of the file used.
If there is no xxx_Info.plist, the file would be generated from the
GNUmakefile as it happens now.
The idea being that you have backwards compatibility, but that new
software would be developed in a different way: -- initially the
programmer just write his simple GNUmakefile, and when he does a make, a
minimal xxx_Info.plist is generated (something like {NSExecutable =
Program;}). If he wants to set the principal class or add an icon or a
nib file, he'd add the variables directly into the xxx_Info.plist. If he
wants to add any other custom variable to the Info.plist, he just adds it
directly. gnustep-make will just copy his Info.plist into the application
directory and that's it.
This would be a lot more efficient in terms of building time, and a lot
simpler, as the programmer just edits his xxx_Info.plist, and what he
writes is what he gets :-)
==
Bundles, palettes and services can work in the same way.
Frameworks are a bit more tricky because they now include the list of
classes in the Info.plist. That is a great feature, and we want to keep
it, but maybe that list of classes could go into a separate .plist ?
Then we avoid the problem of merging the plists.
==