[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Newish threading problems on NetBSD

From: Adam Fedor
Subject: Re: Newish threading problems on NetBSD
Date: Thu, 2 Oct 2003 21:47:21 -0600

On Sunday, September 28, 2003, at 03:40 PM, Peter Cooper wrote:


I've finally got around to compiling a fairly new CVS of GNUstep
on my NetBSD laptop, because I wanted to update the NetBSD build
notes. I've been tracking GNUstep-current happily on a Debian Linux
system during this time.

Unfortunately, sometime between August 16 and a few days ago,
some change was introduced that causes gdnc on NetBSD to explode
either before or when it receives a connection. Strangely, when I run gdnc
standalone with the -f flag, I get a Pth runtime error as soon as
I try to start any GUI app, but when I run it under gdb, it gets killed
by signal 14 - triggered by Pth - well before I have time to run a GUI app.

I think the best way to fix this is to try to narrow the problem down to a smaller date range. Use the -D flag to cvs update to get and compile various versions of gnustep-base (maybe gnustep-gui also, but it appears the problem is in gnustep-base). Perhaps you can narrow it to a single change.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]