[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Newish threading problems on NetBSD

From: Peter Cooper
Subject: Newish threading problems on NetBSD
Date: Sun, 28 Sep 2003 23:40:55 +0200
User-agent: Mutt/1.4i


I've finally got around to compiling a fairly new CVS of GNUstep
on my NetBSD laptop, because I wanted to update the NetBSD build
notes. I've been tracking GNUstep-current happily on a Debian Linux
system during this time.

Unfortunately, sometime between August 16 and a few days ago,
some change was introduced that causes gdnc on NetBSD to explode
either before or when it receives a connection. Strangely, when I run gdnc 
standalone with the -f flag, I get a Pth runtime error as soon as
I try to start any GUI app, but when I run it under gdb, it gets killed
by signal 14 - triggered by Pth - well before I have time to run a GUI app.

In normal use, the error appears to be Pth attempting to find a runnable
thread, and not finding one. This is strange, because it doesn't error
in only slightly older versions of the code running with the same version
of Pth.

So, suggestions on how to properly debug this (I've noticed that there's
no debugtool ;-) or some ideas on where in the code I should look (there
have been changes to gdnc, but nothing that seems obviously the cause
of this...) - would be greatly appreciated.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]