discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Q] CodeEditor, Bug or ... ?


From: NeXT
Subject: Re: [Q] CodeEditor, Bug or ... ?
Date: Sat, 27 Sep 2003 20:56:22 +0900

Neither works! I've got the same error and when I tried to debug it using gdb
I cannot get backtrace because it just exited with 1.

On 2003-09-27 03:57:22 +0900 Yen-Ju Chen <address@hidden> wrote:

Hi,

It works for me on FreeBSD with lastest GNUstep CVS and backart.
Maybe your can try to use the CodeEditor CVS in which I try to fix a potential memory leak.
If it doesn't work, I attach two patches to testing.
They are independent from each other and need to be applied in codeeditor/CodeEditor/. CodeEditor uses built-in text system in order to speed up the syntax highlight. CodeEditorView.m.diff1 reverts it to use the default text system of GNUstep. CodeEditorView.m.diff2 use only the built-in typesetter rather than the whole text system,
and typesetter is where the "defaultLineHeightForFont" comes from.

Please let me know if any of them work.

Yen-Ju

  From: "S.J.Chun" <address@hidden>
Reply-To: S.J.Chun <address@hidden>
To: address@hidden
Subject: [Q] CodeEditor, Bug or ... ?
Date: Fri, 26 Sep 2003 15:13:38 +0900 (KST)

Hi,

I can build and install CodeEditor but I cannot use it without segmentation fault error, actually when I try to type
it just died with above error. It says

CodeEditor: Uncaught exception NSInvalidAgumentException, reason: GSInineArray(instance) does not
recognize defaultLineHeightForFont.

And I've found that it is related with __fonts. Is this a bug in CodeEditor.app or my configuration fault? I'm using art backend and most current CVS of gnustep. I've downloaded CodeEditor from its homepage, not using CVS version.

Thanks in advance.


_______________________________________________
Discuss-gnustep mailing list
address@hidden
http://mail.gnu.org/mailman/listinfo/discuss-gnustep

_________________________________________________________________
Share your photos without swamping your Inbox. Get Hotmail Extra Storage today! http://join.msn.com/?PAGE=features/es






reply via email to

[Prev in Thread] Current Thread [Next in Thread]