discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: #import is obsolete


From: Chris Hanson
Subject: Re: #import is obsolete
Date: Fri, 4 Jul 2003 18:03:20 -0500

On Friday, July 4, 2003, at 04:25  PM, Philippe C.D. Robert wrote:
#import is deprecated, instead #include should be used in conjunction with include guards. See previous threads about this topic.

The #import directive is *not* deprecated in Objective-C and you should *not* switch to #include with include guards; Apple owns the Objective-C language specification and I don't recall them ever saying any such thing.

Yes, there have been plenty of threads about this over the years. Unfortunately, the default build of GCC continues to not conform to the language standard and emit obsolete warnings.

Trying to insist the Mac OS X way of doing, well, anything with respect to Objective-C is broken or obsolete is a waste of time, at least until there's a formal vendor-neutral standards committee for Objective-C that decides to standardize on different behavior. Just conform with it already.

  -- Chris

--
Chris Hanson, bDistributed.com, Inc.  |  Email: address@hidden
Custom Application Development        |  Phone: +1-847-372-3955
http://bdistributed.com/              |  Fax:   +1-847-589-3738
http://bdistributed.com/Articles/     |  Personal Email: address@hidden





reply via email to

[Prev in Thread] Current Thread [Next in Thread]