discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNUstep-base on Darwin


From: LHelldorf
Subject: Re: GNUstep-base on Darwin
Date: Tue, 24 Apr 2001 23:45:34 +0200

Stan Shebs <address@hidden>
24.04.2001 23:22

 
        To:     address@hidden
        cc:     Adam Fedor <address@hidden>, address@hidden
        Subject:        Re: GNUstep-base on Darwin

>address@hidden wrote:
>> 
>> I looked into
>> /usr/include/
>> which links to
>> /System/Library/Frameworks/System.framework/Headers/bsd
>> which links to
>> /System/Library/Frameworks/System.framework/Versions/B/Headers/bsd
>> and in
>> /System/Library/Frameworks/System.framework/Versions/B/Headers/objc
>> but found no occurrence of "TypedStream".
>> Then I looked in objc just for "Stream" and found the following:
>
>These pathnames are only present in OS X PBeta systems and earlier.
>PLEASE upgrade to OS X final!  You're going to waste a lot of
>people's time as they try to chase down problems in prerelease
>software.  One of the big changes we made was to flush all the
>"System framework headers" and just have everything be in
>/usr/include directly, like every other Unix-based system.
>
>From a cursory examination, it looks like the objc-gnu2next.h
>stuff is not appropriate for OS X, since all the NX* functions
>are gone from OS X headers.
>
>Stan

Yes, I run Darwin 1.2.1 because I have to use a PM 8600/250. I already 
tried to upgrade to Darwin 1.3.1. So I downloaded the installer from 
Apple, trashed the previously installed Darwin 1.2.1 and put Darwin 1.3.1 
on that partition. But I wasn't able to get this thing to boot. I tried 
different ways to achive that goal (I used for instance Startup Disk 9.2.1 
(from Darwin 1.3.1), System Disk (version 2.6.2 downloaded from Apple as 
version 3.3), System Disk 3.1 (from Darwin 1.2.1) with different results 
(from absolutely nothing (just OS 9 rebooting) over Open Firmware prompts 
to unability to boot at all - Command-Option-P-R)). I have asked Questions 
about this on address@hidden and (as I got no answer 
there) on address@hidden: again no answers. So I have 
to wait for a possible working Update (maybe Darwin 1.3.2) and to use 
until then Darwin 1.2.1 (I am not happy about this) - if such a Update 
ever will come.

Lars





reply via email to

[Prev in Thread] Current Thread [Next in Thread]