discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Another library irregularity


From: Steve Núñez
Subject: Re: Another library irregularity
Date: Wed, 11 Apr 2001 08:51:21 +0000

This is what leads me to think that there may be some problem. I'm not a 
beginner when it comes to Unix, compilers and building programs, and I'm 
convinced there's something not quite right (or perhaps my understanding of the 
GNUStep environment needs improvement, which is why I'm asking here). 

I have configured these things, in that order, as listed in the installation 
instructions on http://www.made-it.com/GNUstep/Build/idx.html. The fact that 
most of the other packages (seemed) to build correctly makes me think that the 
gnustep-make package is installed correctly. The very first thing I did was add 
the GNUStep.sh line to my .bash_profile, and so I'm sure the environment is set 
up correctly. For some reason, guile doesn't seem to be cooperating, and I'm 
also having trouble running the LogTest example and the 'defaults program as 
well. As an example, here are the results of running LogTest from two different 
directories:

address@hidden gnustep-guile-1.0.0]$ pwd
/home/nunez/GNUStep/gnustep-guile-1.0.0
address@hidden gnustep-guile-1.0.0]$ LogTest
LogTest: error while loading shared libraries: 
/opt/GNUStep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu-xdps/libgnustep-base.so.0:
 undefined symbol: __objc_msg_forward

now if I run it from the directory in which it resides:

address@hidden Tools]$ pwd
/home/nunez/GNUstep/Tools
address@hidden Tools]$ ./LogTest 
Apr 11 08:47:25 LogTest[15950] No local time zone specified.
Apr 11 08:47:25 LogTest[15950] Using time zone with absolute offset 0.
Apr 11 08:47:25 LogTest[15950] Executing

it seems to work, with the exception of the timezone. I get a similar problem 
if I run the 'defaults' program to try and set the timezone:

address@hidden Tools]# defaults write NSGlobalDomain "Local Time Zone" Singapore
defaults: error while loading shared libraries: 
/opt/GNUStep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu-xdps/libgnustep-base.so.0:
 undefined symbol: __objc_msg_forward

and just to prove that I've run GNUStep.sh, here is the output of 'env' (edited 
to show just GNUStep stuff). I notice that the LIBRARY_COMBO is set to xgps, 
and this is what I recall setting it to when configuring gnustep-make (xdps is 
just a bit too unstable for me at the moment, and I need stability); I don't 
know how the other libraries were installed in xdps.

address@hidden Tools]$ env
PWD=/home/nunez/GNUstep/Tools
GNUSTEP_USER_ROOT=/home/nunez/GNUstep
LD_LIBRARY_PATH=/usr/tibco/tibrv/lib
GNUSTEP_HOST=i686-pc-linux-gnu
CLASSPATH=/opt/dev/nunez/cbr/classes:/opt/dev/nunez/cbr/jars/xerces.jar
GNUSTEP_SYSTEM_ROOT=/opt/GNUStep/System
GNUSTEP_LOCAL_ROOT=/opt/GNUStep/Local
MACHTYPE=i386-redhat-linux-gnu
GNUSTEP_FLATTENED=
GNUSTEP_HOST_OS=linux-gnu
LIBRARY_COMBO=gnu-gnu-gnu-xgps
GNUSTEP_MAKEFILES=/opt/GNUStep/System/Makefiles
JAVA_HOME=/usr/java/jdk
GNUSTEP_HOST_VENDOR=pc
GNUSTEP_NETWORK_ROOT=/opt/GNUStep/Network
SHELL=/bin/bash
GNUSTEP_HOST_CPU=ix86
PATH=/usr/local/bin:/home/nunez/bin:/usr/java/jdk/bin:/usr/tibco/tibrv/bin:/home/nunez/GNUstep/Tools/ix86/linux-gnu/gnu-gnu-gnu-xgps:/home/nunez/GNUstep/Tools/ix86/linux-gnu:/home/nunez/GNUstep/Tools:/opt/GNUStep/Local/Tools/ix86/linux-gnu/gnu-gnu-gnu-xgps:/opt/GNUStep/Local/Tools/ix86/linux-gnu:/opt/GNUStep/Local/Tools:/opt/GNUStep/Network/Tools/ix86/linux-gnu/gnu-gnu-gnu-xgps:/opt/GNUStep/Network/Tools/ix86/linux-gnu:/opt/GNUStep/Network/Tools:/opt/GNUStep/System/Tools/ix86/linux-gnu/gnu-gnu-gnu-xgps:/opt/GNUStep/System/Tools/ix86/linux-gnu:/opt/GNUStep/System/Tools:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11R6/bin
GNUSTEP_PATHPREFIX_LIST=/home/nunez/GNUstep:/opt/GNUStep/Local:/opt/GNUStep/Network:/opt/GNUStep/System
GNUSTEP_ROOT=/opt/GNUStep


Am I the only one experiencing these problems? What is the fix?

Regards,

        - SteveN

At 08:34 AM 4/11/01 +0100, Richard Frith-Macdonald wrote:

>On Wednesday, April 11, 2001, at 06:46 AM, Steve Núñez wrote:
>
>>Again in guile. After removing the 'documentation' target from the Greg 
>>subdirectory and compiling/installing, it seems that the libgstep_guile.so.1 
>>library has been placed in yet another directory, 
>>/opt/GNUStep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu-xgps/. Up until this 
>>point, everything had been placed in 
>>/opt/GNUStep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu-xdps/. Note the 
>>difference right at the end: 'xgps' vs. 'xdps'. I was doing reasonably well 
>>by adding the library directory to /etc/ld.so.conf, but am now wondering that 
>>the proper and intended way to handle these GNUStep libraries is. How are 
>>others handling this problem?
>
>I think the bit of GNUstep that is immature is the installation instructions 
>... the information
>is there in the HOWTO, and pretty consistent, but it needs some bits that 
>people keep missing to
>be emphasised.
>
>1. configure, build and install the make package.
>2. SET UP THE ENVIRONMENT using GNUstep.sh
>3. configure build and install the objc library
>4. configure build and install base
>5. configure build and install guile (if you want it)
>6. configure build and install jigs (if you want it)
>
>Remember to setup the environment again whenever you log in.
>
>In the latter stages, the correct library combination will
>be picked up from the environment unless you explicitly
>configure for another library combination - so if you originally
>configured 'make' for xdps, 'guile' will be built for xdps
>too.
>
>If your environment is correctly set up, the GNUstep tools directories
>will be in your path, so all you need to do to run a tool that you
>have built and installed is to type its name.
>
>For a discussion of what the library combinations actually mean,
>see the make package.
>
>
>_______________________________________________
>Discuss-gnustep mailing list
>address@hidden
>http://mail.gnu.org/mailman/listinfo/discuss-gnustep




reply via email to

[Prev in Thread] Current Thread [Next in Thread]