[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error attempting to use AirSpy with osmocom source block

From: Jeff Long
Subject: Re: Error attempting to use AirSpy with osmocom source block
Date: Sat, 17 Jul 2021 16:39:48 -0400

nchan is already a block parameter (nchan=1 in your grc), and it's added for you as numchan, as seen in the args in your error message.

After trying everything else, I deleted the spaces from the args and the error went away!

On Sat, Jul 17, 2021 at 2:41 PM Ellie White <elliewhite1420@gmail.com> wrote:
Hi all,

I hope you're doing well and having a good weekend. I had a question I thought someone here might be able to answer; I'm attempting to get an AirSpy dongle to work properly with GNU Radio but am running into some issues. I attempted to install the right dependencies for the AirSpy (https://github.com/airspy/airspyone_host) and then installed the gr-osmosdr module (the gr-3.8 branch, as I still have GNURadio 3.8 installed), but when I put "airspy=0, bias=1, pack=0" in the "Device Arguments" field of my osmocom Source block and tried running my flowgraph, it gives me the following output:

Generating: '/home/ellie/src/gr-ata/examples/usrp_2chrx.py'

Executing: /usr/bin/python3 -u /home/ellie/src/gr-ata/examples/usrp_2chrx.py

linux; GNU C++ version 7.3.0; Boost_106501; UHD_003.010.003.000-0-unknown

Traceback (most recent call last):
  File "/home/ellie/src/gr-ata/examples/usrp_2chrx.py", line 267, in <module>
  File "/home/ellie/src/gr-ata/examples/usrp_2chrx.py", line 243, in main
    tb = top_block_cls(fc=options.fc, gaindB=options.gaindB, samp_rate=options.samp_rate, src_name=options.src_name, timestamp=options.timestamp)
  File "/home/ellie/src/gr-ata/examples/usrp_2chrx.py", line 131, in __init__
    args="numchan=" + str(1) + " " + 'airspy=0, bias=1, pack=0, nchan=1'
  File "/usr/lib/python3/dist-packages/osmosdr/osmosdr_swig.py", line 1170, in make
    return _osmosdr_swig.source_make(*args, **kwargs)
RuntimeError: Wrong device arguments specified. Missing nchan?

I also tried adding "nchan=1" to the "Device Arguments" field but that didn't work either and resulted in the same error. I've attached my flowgraph for reference. (Note that I made sure my AirSpy dongle was plugged in before running it). Any ideas you might have on how to solve this would be much appreciated, thanks in advance!


Ellie White (she/her)
Physics Major / Student Researcher
Marshall University

reply via email to

[Prev in Thread] Current Thread [Next in Thread]