[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Regarding missing osmocom source

From: Rozana Alam
Subject: Re: Regarding missing osmocom source
Date: Thu, 19 Nov 2020 00:21:26 +0800

Thank you for your detailed clarification, I am really sorry for all the mistakes I have made . I tried to understand your findings. Yes I am using grc 3.8 and sorry for mistakenly giving the grc file of receiving instead of transmitting. I tried to build a loopback block again by considering the maillist help. i tried to transmit a 3.7 Gig signal through balderf and receive the signal by the loopback osmosink. Later I want to measure the signal through a spectrum analyser. may i get help to get the correctness of the block?

On Wed, Nov 18, 2020 at 11:27 PM Christophe Seguinot <christophe.seguinot@orange.fr> wrote:


About Osmocom-sink

  • It seems that you have gr-osmosdr installed since your flowgraph has one osmocom-source.
  • What you need is an osmocom-sink and if you have osmocom-source you must also have osmocom-sink too!!
  • so What is you GR version, and do you have installedgr-osmocom?
  • It seems that you are using GR 3.8 or 3.9, see on this list how to use gr-osmocom on GR3.8

About your simulation. It seems to me that you don't have knowledge about Equivalent baseband representation  (see recent discussions on this list and on line tutorial before using GNURadio) as well as signal sampling :

  • When dealing with a F0=3.4 GHz signal
    • Center frequency is set to 3.4 GHz for hardware (osmocom) sink and sources
    • Signal delivered at output is of hardware source and at input of hardware sink are complex  equivalent baseband signals centered on 0Hz.
    • Simulated signal source must be complex at 0Hz to simulate the corresponding signal at 2.4 GHz

The attached flowgraph (GR3.9 or 3.8) and figure simulates 3 signals at baseband :

  • Data1 at 0 Hz which appears at 3.400 GHz since we told the spectrum analyzer to center spectrum at 3.4 GHz (Changing the Frequency axis is an artefact to get a representation corresponding to the real signal at 3.4 GHz captured by a source or generated by an hardware sink)
  • Data2 at F0=10 MHz which appears at 3.4GHz + 10 MHz (normal you can try any F0 value in the range [-Fs/2, Fs/2]
  • Data0 (your signal source) at F0=3.4 Ghz which is NOT at 3.4 GHz ! Why ?
  • A F0=3.4 GHz signal  sampled at Fs=61.44 MHz have peaks in its spectrum at every frequency Fn such as Fn=F0 +n Fs
    • chose N=-53 : F53= F0 -53 Fs = 20.8 Mhz . This is the only one peak seen in the [-Fs/2, Fs/2] frequency band of simulation
  • Since we told the spectrum analyzer to center spectrum at 3.4 GHz, this peak appears at 3.4G + 20.8 Mhz = 3420.8MHz
  • Fo data0 source we can conclude that :
    • this signal is equivalent to a 20.8 MHZ baseband signal
    • F0 to any value such as 20.8 MHz+kFs  (k integer) will give the exact same results 3.4 GHz is one of these values)

Regards, Christophe

On 18/11/2020 11:20, Rozana Alam wrote:
Hello community,
I am trying to transmit  continuous waves (CW signal)  using bladeRF through gnu-radio. i can see the transmitting signal through QT-Gui but i can't receive the signal in network analyser. In the gnu block i have used signal source and osmocom sink to transmit signal. I am attaching my grc file and snapshots for your reference. I would really appreciate your help.

On Wed, Nov 4, 2020 at 4:39 PM Rozana Alam <rozana.alam0@gmail.com> wrote:
Hello community,
I want to generate simple continuous wave with bladeRF using gnu radio and am a Linux user.but in the gnu platform I am not getting any osmocom source.i have downloaded the gnu from ppa .is there any supplement of osmocom source to generate signal by bladeRF?
Your suggestions are highly appreciated.
Best regards,

Attachment: 1611.png
Description: PNG image

Attachment: 1612.png
Description: PNG image

Attachment: cw_tx_rx.grc
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]