[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ALSAPulseAudio procedure

From: Cinaed Simson
Subject: Re: ALSAPulseAudio procedure
Date: Sun, 5 Jul 2020 18:29:57 -0700
User-agent: Mozilla/5.0 (X11; Linux i686; rv:68.0) Gecko/20100101 Thunderbird/68.10.0

Okay, I stand corrected - I've only tried to use  once about a couple of years ago.

If I can't open a GRC in email then I don't look at it.

I'm lazy.

On 7/3/20 4:02 AM, Barry Duggan wrote:

Just as one has to do with getting a file from Github, you have to click on the 'Raw' button before you copy the file with your text editor. Once you do that, you will have the correct format.

I don't download individual files from github either - I just copy the URL and do a git clone on my desktop.

For good measure, attached is the grc file.


BTW, Ryan gave me the info I needed about the PulseAudio page.

Barry Duggan KV4FV

On 7/3/20 4:28 AM, Cinaed Simson wrote:
Hi Barry - the GRC isn't an image or binary file - it's a text based XML file.

Send it as an attachment to your email.

If I recall correctly, uploading a GRC file to pastbin.com and then downloading it destroys the flow graph (the XML formatting) and reduces the GRC flowgraph to a stack of text from the blocks.

Try it.

-- Cinaed

On 7/2/20 4:26 AM, Barry Duggan wrote:
Hi Cinaed,

The Pluto_NFM.grc is in https://pastebin.com/XZN0dK6x  I have found that reducing the buffer size on the Pluto almost eliminated the audio underruns.

So what I am left with is needing to know what is wrong with the procedure in https://wiki.gnuradio.org/index.php/ALSAPulseAudio#Monitoring_the_output_of_your_system

I have been doing a lot of documentation updates and would like to correct / improve that page.

Thanks for your help.
Barry Duggan KV4FV

On 7/1/20 4:53 PM, Cinaed Simson wrote:
Hi Barry - can you post the GRC file (no images please) for when the audio doesn't work correctly?

-- Cinaed

On 7/1/20 5:43 AM, Barry Duggan wrote:
Hi Cinaed,

Thank you for your response. Yes, I have tried those and the "hw:CARD=Generic,DEV=0" works well for most flowgraphs. I obtained that from the 'aplay -L' command.

Let me reiterate my request: In exploring the audio problems, I followed the instructions in https://wiki.gnuradio.org/index.php/ALSAPulseAudio#Monitoring_the_output_of_your_system and it gave the error I cited. So what I want to know is: Did I do something wrong, or is the procedure not correct?

I need someone who is familiar with the ALSA and PulseAudio software to look at this.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]