[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] RTTY receiver

From: Barry Duggan
Subject: Re: [Discuss-gnuradio] RTTY receiver
Date: Thu, 13 Jun 2019 07:22:19 -0400
User-agent: Roundcube Webmail/1.3.8

Hi Kyeong and all the others who helped me on this issue!

Ron Economos identified the basic problem: it depends on how gnu radio was loaded as to whether to use '/usr/local' or '/usr'. So I tried
'cmake -DCMAKE_INSTALL_PREFIX=/usr ../' and it works :)

Also, per your suggestion, I rebuilt without the '-DCMAKE_INSTALL_PREFIX=/usr', followed by "sudo ldconfig", and that works as well.

So, this issue is closed. I will be submitting a change I made to get 'baudot_encode_bb_impl.cc' to compile, along with suggested additions to the README for installation instructions (for newbees like me).

Thanks again, Barry KV4FV

P.S. Since I didn't get an email from Ron Economos directly, I can't respond to him right now. The system presents a button to "reply via email to" the person, but I don't have an email client loaded in my rPi yet... I'm using a webmail interface right now.
Barry Duggan
cell: 256-426-0824

On 2019-06-12 23:20, Kyeong Su Shin wrote:
Hello Barry:

I replicated this on my Pi, and "sudo ldconfig" fixed it. Could you
try that, if you haven't already

The runtime path of the swig source library is set to "" like in
yours, but it does not prevent the script from running (at least on my
machine (tm)).

(I always run "sudo ldconfig" after installing a GNU Radio module,
because many modules simply require that to function properly.)


Kyeong Su Shin

보낸 사람: Barry Duggan <address@hidden>
보낸 날짜: 2019년 6월 13일 목요일 오전 9:26:11
받는 사람: Muller, Marcus (CEL); Kyeong Su Shin
참조: Discuss Gnuradio; Cinaed Simson
제목: Re: [Discuss-gnuradio] RTTY receiver

Here is my current status.

I performed the following commands in the
/home/pi/gr-radioteletype/build directory:

pi@raspberrypi:~/gr-radioteletype/build $ make clean
pi@raspberrypi:~/gr-radioteletype/build $ cmake ../
-- Build type not specified: defaulting to release.
-- Boost version: 1.62.0
-- Found the following Boost libraries:
--   filesystem
--   system
Checking for GNU Radio Module: RUNTIME
  * INCLUDES=/usr/include
-- Extracting version information from git describe...
-- Using install prefix: /usr/local
-- Building for version: 3a00e28a / 1.0.0git
-- Checking for module SWIG
-- Found SWIG version 3.0.10.
-- Configuring done
-- Generating done
-- Build files have been written to: /home/pi/gr-radioteletype/build
pi@raspberrypi:~/gr-radioteletype/build $ make
[  4%] Building CXX object
[  8%] Building CXX object
[ 12%] Building CXX object
[ 16%] Building CXX object
[ 20%] Building CXX object
[ 24%] Linking CXX shared library libgnuradio-radioteletype-1.0.0git.so
[ 24%] Built target gnuradio-radioteletype
[ 28%] Building CXX object
[ 32%] Building CXX object
[ 36%] Linking CXX executable test-radioteletype
[ 36%] Built target test-radioteletype
[ 40%] Building CXX object
[ 44%] Linking CXX executable _radioteletype_swig_doc_tag
[ 44%] Built target _radioteletype_swig_doc_tag
[ 48%] Generating doxygen xml for radioteletype_swig_doc docs
[ 52%] Generating python docstrings for radioteletype_swig_doc
[ 52%] Built target radioteletype_swig_swig_doc
[ 56%] Building CXX object
[ 60%] Linking CXX executable _radioteletype_swig_swig_tag
[ 60%] Built target _radioteletype_swig_swig_tag
[ 64%] Generating radioteletype_swig.tag
Scanning dependencies of target radioteletype_swig_swig_2d0df
[ 68%] Building CXX object
[ 72%] Linking CXX executable radioteletype_swig_swig_2d0df
Swig source
[ 72%] Built target radioteletype_swig_swig_2d0df
[ 76%] Generating radioteletype_swig.pyc
[ 80%] Generating radioteletype_swig.pyo
[ 80%] Built target pygen_swig_07109
Scanning dependencies of target _radioteletype_swig
[ 84%] Building CXX object
[ 88%] Linking CXX shared module _radioteletype_swig.so
[ 88%] Built target _radioteletype_swig
[ 92%] Generating radioteletype/__init__.pyc, radioteletype/filters.pyc,
radioteletype/modulators.pyc, radioteletype/demodulators.pyc
[ 96%] Generating radioteletype/__init__.pyo, radioteletype/filters.pyo,
radioteletype/modulators.pyo, radioteletype/demodulators.pyo
[ 96%] Built target pygen_python_17c4d
[ 96%] Built target pygen_apps_9a6dd
[100%] Generating documentation with doxygen
[100%] Built target doxygen_target
pi@raspberrypi:~/gr-radioteletype/build $ sudo make install
[ 24%] Built target gnuradio-radioteletype
[ 36%] Built target test-radioteletype
[ 44%] Built target _radioteletype_swig_doc_tag
[ 52%] Built target radioteletype_swig_swig_doc
[ 60%] Built target _radioteletype_swig_swig_tag
[ 72%] Built target radioteletype_swig_swig_2d0df
[ 80%] Built target pygen_swig_07109
[ 88%] Built target _radioteletype_swig
[ 96%] Built target pygen_python_17c4d
[ 96%] Built target pygen_apps_9a6dd
[100%] Built target doxygen_target
Install the project...
-- Install configuration: "Release"
-- Up-to-date:
-- Up-to-date: /usr/local/include/radioteletype/api.h
-- Up-to-date: /usr/local/include/radioteletype/varicode_decode_bb.h
-- Up-to-date:
-- Up-to-date: /usr/local/include/radioteletype/baudot_decode_bb.h
-- Up-to-date: /usr/local/include/radioteletype/varicode_encode_bb.h
-- Up-to-date: /usr/local/include/radioteletype/baudot_encode_bb.h
-- Installing:
-- Up-to-date: /usr/local/lib/libgnuradio-radioteletype-1.0.0git.so
-- Up-to-date: /usr/local/lib/libgnuradio-radioteletype.so
-- Up-to-date: /usr/local/lib/libgnuradio-radioteletype-1.0.0git.so.0
-- Installing:
-- Set runtime path of
to ""

Then when I execute the flow graph, I get
Generating: '/home/pi/gr-radioteletype/examples/rtty_demod.py'

Executing: /usr/bin/python -u

Warning: failed to XInitThreads()
Traceback (most recent call last):
   File "/home/pi/gr-radioteletype/examples/rtty_demod.py", line 30, in
     from radioteletype.demodulators import rtty_demod_cb
line 9, in <module>
     from radioteletype_swig import (
line 21, in <module>
     _radioteletype_swig = swig_import_helper()
line 20, in swig_import_helper
     return importlib.import_module('_radioteletype_swig')
   File "/usr/lib/python2.7/importlib/__init__.py", line 37, in
ImportError: No module named _radioteletype_swig

So even though 'cmake' figured out the install path, the install script
set the runtime path to "".
Is there a command line define where I need to specify the runtime path?

Thanks, Barry
Barry Duggan
cell: 256-426-0824

reply via email to

[Prev in Thread] Current Thread [Next in Thread]