[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] Getting "Environment Error" when trying to use US

From: Jose Ruvalcaba
Subject: Re: [Discuss-gnuradio] Getting "Environment Error" when trying to use USRP X310
Date: Tue, 7 May 2019 10:14:41 -0700

Hi Marcus,

I was using a 1 Msps sample rate in my flowgraph. As for the Ethernet controller, I was currently using my standard 1 GigE Ethernet port on my PC, however, this issue also shows up when using a 10GigE connection. If it helps, the 10 GigE Ethernet card I have is the desktop card sold by Ettus Research.


On Tue, May 7, 2019 at 8:07 AM Marcus D. Leech <address@hidden> wrote:
On 05/07/2019 02:23 AM, Jose Ruvalcaba wrote:

I recently installed GNU Radio with UHD 3.14 ,using PyBOMBS, and tried to use my X310 radio with it. It asked me to update its FPGA image, and after updating it, I began to see an error whenever I tried using the USRP sink and source block In GNU Radio. The error reads:

Executing: /usr/bin/python2 -u /home/satrnground/Downloads/simple_xponder.py
[32;1m[INFO] [UHD] [39;0mlinux; GNU C++ version 7.3.0; Boost_106501; UHD_3.14.0.0-110-g6af6ac32
[32;1m[INFO] [X300] [39;0mX300 initialization sequence...
[32;1m[INFO] [X300] [39;0mMaximum frame size: 1472 bytes.
[32;1m[INFO] [X300] [39;0mRadio 1x clock: 200 MHz
[31;0m[ERROR] [UHD] [39;0mException caught in safe-call.
  in ctrl_iface_impl<_endianness>::~ctrl_iface_impl() [with uhd::endianness_t _endianness = (uhd::endianness_t)0]
  at /home/satrnground/prefix/src/uhd/host/lib/rfnoc/ctrl_iface.cpp:60
this->send_cmd_pkt(0, 0, true); -> EnvironmentError: IOError: Block ctrl (CE_00_Port_30) no response packet - AssertionError: bool(buff)
  in uint64_t ctrl_iface_impl<_endianness>::wait_for_ack(bool, double) [with uhd::endianness_t _endianness = (uhd::endianness_t)0; uint64_t = long unsigned int]
  at /home/satrnground/prefix/src/uhd/host/lib/rfnoc/ctrl_iface.cpp:155

Note that I am NOT trying to use RFNOC, which I think this issue is related too, I am just trying to use the x310 with regular USRP blocks in GNU radio.If it helps to know, I am running UBuntu 18.04 and the FPGA image I downloaded on my X310 was the default HG one. Can anyone shine some light into how to get rid of this issue?

Jose R

What sample rate are you using?  Do you happen to know what type of Ethernet controller your PC has?

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]