[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Discuss-gnuradio] First attempt at GRC crash and burn

From: cliff palmer
Subject: Re: [Discuss-gnuradio] First attempt at GRC crash and burn
Date: Sun, 27 Jan 2019 11:53:57 -0500

Thanks for your reply, Cinaed.  I solved the problem by attaching the antenna.  

On Sat, Jan 26, 2019 at 5:35 PM Cinaed Simson <address@hidden> wrote:
Try from a command line window


This will give the serial number - but if you only have one HackRF
device you don't need it - leave the device blank.

But for future reference, the serial number should look like this


The number you want to use is


or the last 8 characters.

I'm presuming the drivers for the HackRF have been installed.

It's possible since it's Windows that there's a USB problem.

I don't know anything about Windows - but if you can't access the device
then Google should be able to help you.

-- Cinaed

On 1/26/19 2:00 PM, cliff palmer wrote:
> My first attempt at using GNU Radio Companion produced this error log:
> ------ begin error log ------
> <<< Welcome to GNU Radio Companion >>>
> Block paths:
> G:\GNURadio-3.7\share\gnuradio\grc\blocks
> Loading: "C:\Users\Cliff\Documents\lesson1.grc"
>>>> Done
> Generating: 'C:\\Users\\Cliff\\Documents\\top_block.py'
> Executing: G:\GNURadio-3.7\gr-python27\python.exe -u
> C:\Users\Cliff\Documents\top_block.py
> gr-osmosdr 4d83c606 (0.1.5git) gnuradio
> built-in source types: file osmosdr fcd rtl rtl_tcp uhd hackrf bladerf
> airspy redpitaya 
> [INFO] [UHD] Win32; Microsoft Visual C++ version 14.0; Boost_106000;
> UHD_3.13.0.1-0-unknown
> Traceback (most recent call last):
>   File "C:\Users\Cliff\Documents\top_block.py", line 102, in <module>
>     main()
>   File "C:\Users\Cliff\Documents\top_block.py", line 96, in main
>     tb = top_block_cls()
>   File "C:\Users\Cliff\Documents\top_block.py", line 64, in __init__
>     self.osmosdr_source_0 = osmosdr.source( args="numchan=" + str(1) + "
> " + '' )
>   File "G:\GNURadio-3.7\lib\site-packages\osmosdr\osmosdr_swig.py", line
> 1330, in make
>     return _osmosdr_swig.source_make(*args, **kwargs)
> RuntimeError: No supported devices found (check the connection and/or
> udev rules).
>>>> Done
> ------- end of error log ------
> I am running GRC on a Windows 10 Pro workstation.
> I am using a Hack RF One from Great Scott Gadgets which has a label on
> the side "r4-p6" but does not identify this as a model/rev ID.
> I ran the first example from Great Scott Gadgets Hack RF One Tutorials
> which is located here: https://greatscottgadgets.com/sdr/1/
> This example combines the OSMOCOM Souce and WX GUI FFT Sink modules.
> I have attached the grc file, the top_block.py and the GRC configuration
> file.
> The error occurred when I clicked on the "Execute the Flow Graph" Icon.
> I would appreciate any help getting past this error.
> Thanks!
> _______________________________________________
> Discuss-gnuradio mailing list
> address@hidden
> https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

Discuss-gnuradio mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]