[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Dino-list] Fresh installation dion problems

From: Lars Luthman
Subject: Re: [Dino-list] Fresh installation dion problems
Date: Fri, 25 Mar 2011 18:58:07 +0100

On Thu, 2011-03-24 at 22:40 +0100, address@hidden wrote: 
> I run make and get:
> g++: command not found
> so I had to install it - on Fedora 14 it is in gcc-c++ package.
> May be it is good idea to add g++ to requirements section ?

Yes, maybe I should mention it somewhere.

> Finaly I installed Dino.
> But another problems appear.
> First I start up JACK.
> 1. Then I run lashd and get message:
> JACK error: Cannot lock down memory area (Cannot allocate memory)

This looks like a problem with JACK, you will probably get the same
message from any JACK client. You don't have your system set up to allow
your user to lock memory, which JACK clients need to do to run in

> Connected to JACK server with client name 'LASH_Server'
> Opened ALSA sequencer with client ID 130
> conn_mgr_start: could not create listen socket
> loader_run: server closed socket; exiting

Not sure why you get this, from the Dino output below Dino obivously
connects to a running lashd so it must be working somehow.

> 2. I run dino and get message:
> (dino:8278): libglade-WARNING **: Error loading image: Failed to open 
> file './head.png': No such file or directory
> [...]

Are you running it with the Dino source directory as current working
directory? For some reason it doesn't find the installed graphics files
when you do that, but it's easily worked around by just changing
directory to somewhere else.

> JACK: Cannot lock down memory area (Cannot allocate memory)
> JACK: Cannot use real-time scheduling (RR/15)(1: Operation not permitted)
> JACK: AcquireRealTime error

Again, a JACK client (Dino this time) is for some reason not allowed to
lock memory and schedule its threads to run with realtime privileges.

> lash_init: Not attempting to start daemon server automatically
> Created project project-1 in directory /home/tomek/audio-projects/project-1
> Added client a7d44f39-2cd3-498a-8aa9-b690bc24c387 of class dino to 
> project project-1
> Client a7d44f39-2cd3-498a-8aa9-b690bc24c387 set its name to 'Dino'
> I/O warning : failed to load external entity "output.dino"

This is all normal. Most of it is chatter from liblash, and the last
line is related to the LADISH support and can safely be ignored if you
don't use LADISH.

> 3. When I click "Add new track" in "midi ports" I can chose only None.

This menu lists the available JACK MIDI input ports on the system. Do
you have any programs with JACK MIDI input ports running, or are you
telling JACK to mirror your ALSA hardware or sequencer ports (the -X raw
or -X seq options to the jackd alsa driver) ? If not, the menu will only
show the option "None".

> 4. In Jack audio connections kit - provided by qjackctl I can not see 
> dino - although play/stop capabilities seem to cooperate with qjackctl 
> play/stop.

MIDI output ports are created for every track in Dino, so if you have
added any tracks they _should_ show up in the MIDI section in QJackCtl.


Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]