[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Dazuko-devel] 2.3.1-pre3 posted

From: Tikka, Sami
Subject: RE: [Dazuko-devel] 2.3.1-pre3 posted
Date: Fri, 1 Sep 2006 17:19:45 +0300

The dazuko 2.3.1-pre3 fails to build on SuSE Enterprise Desktop / Server 10.

Simply running "./configure ; make" produces errors like this:

*** You have not yet configured your kernel!
*** Please run some configurator (e.g. "make oldconfig" or
*** "make menuconfig" or "make xconfig").

This is apparently because configure printed:

kernel build source in /lib/modules/ Yes

If I run "./configure --kernelobjdir=/lib/modules/ ;
make", everything works properly.

Is this how it is supposed to work? I would prefer if configure script could
locate the proper kernel headers automatically.

-- Sami

>-----Original Message-----
>From: address@hidden 
>] On Behalf Of John Ogness
>Sent: Tuesday, August 29, 2006 6:11 PM
>To: address@hidden
>Subject: [Dazuko-devel] 2.3.1-pre3 posted
>I received a patch for the configure script from SUSE to allow 
>Dazuko to be built by their automated systems. The configure 
>script now has an additional option --kernelobjdir that can 
>point to where the kernel build source files are located. This 
>was previously possible with the --kernelsrcdir option.
>However, on some distributions the source dir and the object 
>(build source) dir are not the same.
>The new changes shouldn't affect systems where the configure 
>script correctly worked before.
>Unless problems are reported this week, 2.3.1 will become the 
>new official stable version next week.
>John Ogness
>Dazuko Maintainer
>Dazuko-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]