commit-gnue
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gnue] r8973 - trunk/gnue-common/src/definitions


From: jcater
Subject: [gnue] r8973 - trunk/gnue-common/src/definitions
Date: Wed, 1 Nov 2006 23:50:02 -0600 (CST)

Author: jcater
Date: 2006-11-01 23:50:01 -0600 (Wed, 01 Nov 2006)
New Revision: 8973

Modified:
   trunk/gnue-common/src/definitions/GParser.py
Log:
the object_created virtual function was happening at the wrong time and also 
didn't stick to the GNUe naming convention of _virtual_func_().

Modified: trunk/gnue-common/src/definitions/GParser.py
===================================================================
--- trunk/gnue-common/src/definitions/GParser.py        2006-10-31 18:34:19 UTC 
(rev 8972)
+++ trunk/gnue-common/src/definitions/GParser.py        2006-11-02 05:50:01 UTC 
(rev 8973)
@@ -565,9 +565,10 @@
         if self.xmlStack [0] != None:
           GContent (self.xmlStack [0], text)
 
+    # Let any subclasses know that the object was created
+    self._object_created_(object)
 
 
-
   # ---------------------------------------------------------------------------
   # Process text which is not part of a tag (=contents)
   # ---------------------------------------------------------------------------
@@ -622,12 +623,10 @@
 
     assert gDebug (7, "</%s>" % tname)
 
-    self.object_created(child)
-
   # ---------------------------------------------------------------------------
-  # Get the root comments sequence
+  # Virtual functions
   # ---------------------------------------------------------------------------
-  def object_created(self, obj):
+  def _object_created_(self, obj):
       pass
 
 





reply via email to

[Prev in Thread] Current Thread [Next in Thread]