[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Chicken-users] chicken hangs and uses 100% cpu (mac os x lion)

From: Topher Cyll
Subject: [Chicken-users] chicken hangs and uses 100% cpu (mac os x lion)
Date: Tue, 13 Sep 2011 20:56:26 -0400

Hey everyone,

Like a previous poster, I'm having issues with Chicken on Mac OS X
(although for me the issues are on Lion, not Snow Leopard).

I started building from MacPorts (4.4.0) and had the same issue as the
previous poster.  The build succeeds, but trying to run csc or csi
results in what appears to be an infinite loop (no output and 100% cpu

Since then, I've built from the source releases for: 4.7.0, 4.6.0,
4.5.0, 4.4.0, 4.3.0, 4.2.0, 4.1.0, and 4.0.0.  All of them build
correctly, but when I run "install", the process hangs on
"chicken-install -update-db" and cpu usage goes to 100% again.

I've also tried building from HomeBrew (4.7.0) and it also hangs while
updating the db.

Am I right that chicken-install is executing code written in chicken?
I'm not completely positive this is the same problem, but it seems

Also, I'm not sure I did this right, but I tried to do a system trace
using Instruments (which ships with XCode).  I was hoping for a
smoking gun, but all I see is this repeated over and over again:


Not sure how to interpret that, although it seems like something
involving signal handlers might be unhappy?

Anyone else bumped into this?  I'm happy to try to figure out what's
going on if anyone has any suggestions.  Is there any way to build a
debug version of chicken?

Thanks everyone,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]