[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Chicken-users] Re: Trouble with easyffi

From: bill
Subject: [Chicken-users] Re: Trouble with easyffi
Date: Fri, 26 Jun 2009 15:28:45 -0400
User-agent: Thunderbird (X11/20090409)


I think we're talking at cross purposes here. I thought you meant when I compiled (installed) easyffi. I have two old programs that worked fine on Gentoo (with I believe chicken 3.4). Both link into Gtk. I have recently tried running a little app to test Cairo.

All of these give me no errors with I compile them. The only error comes when I try to run them - the 'foreign parse' error.

On the Gtk programs most of the code is just calling scheme described call to Gtk. For instance:

    GtkWidget *gtk_hpaned_new(void);

void gtk_widget_set_size_request(GtkWidget *widget, int width, int height);

which are used thus in chicken:

(define hpane (gtk_hpaned_new)) (gtk_widget_set_size_request hpane 1200 650))

Some of the code is actual C code snippets that are defined as this:


 char *get_text(GtkTextBuffer *tbuffer)
   GtkTextIter s_iter;
   GtkTextIter e_iter;

   gtk_text_buffer_get_start_iter(tbuffer, &s_iter);
   gtk_text_buffer_get_end_iter(tbuffer, &e_iter);
return gtk_text_buffer_get_text(tbuffer, &s_iter, &e_iter, FALSE);


If this does not help, I can put together a small app that I can send you. One of the failing programs is my own editor and a bit too big to send - although I have no qualms in doing so.

Again, all of this worked before moving to Xubunto and Chicken 4.0. Could some library be missing?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]