[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] base64 module naming

From: Kon Lovett
Subject: Re: [Chicken-users] base64 module naming
Date: Sun, 7 Sep 2008 14:37:42 -0700

On Sep 1, 2008, at 2:44 PM, Jim Ursetto wrote:

Style question: the Chicken 3 version of base64 consists of two
procedures: base64:encode and base64:decode.  For the modularized
version in Chicken 4, should the prefix simply be stripped ("encode",
"decode"), or should they be more descriptive, such as base64-encode
and base64-decode?

I'm leaning toward the latter, because I don't think a namespace is a
substitute for a properly descriptive name.

I agree. But ...

 Taken too far, the former
might lead to modules with a single procedure called "go", "do" or
"execute".  And a (require-extension base64) that pulls in "encode"
and "decode" is nearly useless -- the module system serving to
exacerbate rather than diminish namespace conflicts.

But, I can understand that some may prefer to deal with the
disambiguation at the module level.  Does anyone have any thoughts?

This is a very soft area. While "encode" is probably too ambiguous what about "encipher"? "broadcast" is questionable but what about "disseminate"? I guess it comes down to is it clear from context.

I admit to not being a big fan of generic sounding names for rather specific operations.

Chicken-users mailing list

Best Wishes,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]