[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-hackers] parallel build failure

From: Mario Domenech Goulart
Subject: Re: [Chicken-hackers] parallel build failure
Date: Fri, 04 Mar 2011 21:11:54 -0500
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1.91 (gnu/linux)

Hi Jim,

On Fri, 4 Mar 2011 11:36:20 -0600 Jim Ursetto <address@hidden> wrote:

> On Fri, Mar 4, 2011 at 01:38, Jim Ursetto <address@hidden> wrote:
>> Spoke too soon :(.  I had 5 or 6 successful builds on two machines but
>> 1 failure on a different machine (at -j4).
> If anyone wants to be a guinea pig, you can try the patch at:
> I was able to build with -j4 and -j8 (fingers crossed).  It addresses
> two intermittent build errors: 1) importing setup-api before it has
> been built; 2) linking with libchicken before it has been built.

I've tried your patch but, unfortunately it doesn't work for me here
(dual-core, Linux x86).

For the commands below, consider that they are run from the chicken-core
directory and that I run

  $ export PLATFORM=linux

If I try

  $ git clean -f && make boot-chicken
  $ touch *.scm && make CHICKEN=./chicken-boot spotless all

everything goes well.  The build is finished without errors.

However, if add -j2, "make boot-chicken" is finished without errors, but
"make CHICKEN=./chicken-boot all" dies with:

./chicken-boot setup-api.import.scm -optimize-level 2 -include-path
. -include-path ./ -inline -ignore-repository -feature chicken-bootstrap
-no-warnings  -feature chicken-compile-shared -dynamic -no-trace
-output-file setup-api.import.c
ar cru  libchicken.a apply-hack.x86.o library-static.o eval-static.o
data-structures-static.o ports-static.o files-static.o extras-static.o
lolevel-static.o utils-static.o tcp-static.o srfi-1-static.o
srfi-4-static.o srfi-13-static.o srfi-14-static.o srfi-18-static.o
srfi-69-static.o posixunix-static.o irregex-static.o scheduler-static.o
profiler-static.o stub-static.o expand-static.o chicken-syntax-static.o
chicken-ffi-syntax-static.o runtime-static.o
ar: apply-hack.x86.o: No such file or directory

The error is reproducible.

I also tried building with fingers crossed, but that doesn't help.

Best wishes.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]