[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [certi-dev] Help with Certi Demos

From: Pierre Siron
Subject: Re: [certi-dev] Help with Certi Demos
Date: Wed, 27 Apr 2016 14:04:31 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.7.0

Bonjour Constantinos,
I have tested this program with an old version of PtII
and it seems working.

"the “rtig” is not called"

You could try to launch manually the rtig before PtII.

In the first terminal :
cd $PTII/org/hlacerti/demo/Billard

In the second :
vergil FederationBillard.xml

Something happens ?

Bien cordialement,

Le 26/04/2016 21:26, Constantinos Heracleous a écrit :
Hello to all,

I’m new to CERTI and I’m having difficulties to run the demos and I would like a bit of help.
I have successfully installed PTII and CERTI on Mac OSX following the User Manual for HLA-PTII federates (Updated after revision r73687, October, 20, 2015.). I’ve also tested the installation (using three terminals) as explained in the same manual and after I did some configurations in the .bash_profiled it worked fine. Now I’ve been trying to run the demo $PTII/org/hlacerti/demo/Billard/FederationBillard.xml from the graphical interface with no luck.
Specifically, I start the terminal (source $HOME/pthla/certi/share/scripts/myCERTI env.sh is in .bash_profile so runs at the beginning) and then I execute: vergil $PTII/org/hlacerti/demo/Billard/FederationBillard.xml & to open the graphical interface.
Then I run the two model in order: TwoBillarBalls.xml and then PoolTable2.xml (creator is set in the last).
Unfortunately, nothing happens, the “rtig” is not called to run and the twovergil $PTII/org/hlacerti/demo/Billard/FederationBillard.xml models remain at initializing.

Here is what I get in the terminal that might be helpful:

Last login: Tue Apr 26 21:53:27 on ttys000

CERTI version <3.5.1>

Current machine architecture is <x86_64>.

Your PATH variable has been modified for scripts


** WARNING ** We hope you have made source myCERTI.sh **


If yes your variables for CERTI are now :

CERTI_HOST      =  localhost

CERTI_HOME      =  /Users/Constantinos/pthla/certi-tools

CERTI_FOM_PATH  =  /Users/Constantinos/pthla/certi-tools/share/federations

PATH            =  /Users/Constantinos/pthla/certi-tools/share/scripts:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/TeX/texbin:/Users/Constantinos/ant/bin:/Users/Constantinos/pthla/ptII/bin:/Users/Constantinos/pthla/certi-tools/bin

LD_LIBRARY_PATH =  /Users/Constantinos/pthla/certi-tools/lib:

DYLD_LIBRARY_PATH =  /Users/Constantinos/pthla/certi-tools/lib:

MacBook-Pro:~ Constantinos$ vergil $PTII/org/hlacerti/demo/Billard/FederationBillard.xml &

[1] 43333

MacBook-Pro:~ Constantinos$ CertRtig: the os.name property is: Mac OS X

CertiRtig: .TwoBilliardBalls.HlaManager: About to invoke rtig: 

command: [/bin/sh, -c, /Users/Constantinos/pthla/certi-tools/bin/rtig, Test.fed]

environment: [DYLD_LIBRARY_PATH=/Users/Constantinos/pthla/certi-tools/lib]

directory: /Users/Constantinos/pthla/ptII/org/hlacerti/demo/Billard

CertRtig: the os.name property is: Mac OS X

CertiRtig: .PoolTable2.display: About to invoke rtig: 

command: [/bin/sh, -c, /Users/Constantinos/pthla/certi-tools/bin/rtig, Test.fed]

environment: [DYLD_LIBRARY_PATH=/Users/Constantinos/pthla/certi-tools/lib]

directory: /Users/Constantinos/pthla/ptII/org/hlacerti/demo/Billard

MacBook-Pro:~ Constantinos$ 

I can’t figure out if I have set something wrong so I’m stuck, if you can suggest anything to try it would be very helpful.

Thank you,

Constantinos Heracleous
Researcher | KIOS Research Center, University of Cyprus
email: address@hidden
web: www.constantinosheracleous.com

reply via email to

[Prev in Thread] Current Thread [Next in Thread]