[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [certi-dev] CERTI setup

From: Charles Lesire-Cabaniols
Subject: Re: [certi-dev] CERTI setup
Date: Tue, 19 Jul 2011 15:38:55 +0200

Hi John,

I effectively had the same error because of my http_proxy variable set to my work proxy.
I solved the problem by unsetting it, but I guess you can also set a CERTI specific proxy by defining:

Let me know if it works for you.



2011/7/19 John Schroeder <address@hidden>

On Tue, Jul 19, 2011 at 12:05 AM, Eric Noulard <address@hidden> wrote:
2011/7/19 John Schroeder <address@hidden>:
> Hello all,
> I am very new to HLA programming and not all that familiar with network
> security protocols.  As a consequence, I have not been able to get the CERTI
> RTI to run on any platform I have access to.  I have tried WindowsXP,
> Ubuntu, and Fedora 15.  The following is what happens when I try to start
> rtig on my Fedora 15 system:
> address@hidden CERTI-3.4.0-Source]$ rtig
> CERTI RTIG 3.4.0 - Copyright 2002-2008  ONERA
> This is free software ; see the source for copying conditions. There is NO
> terminate called after throwing an instance of 'certi::NetworkError'
> Aborted (core dumped)
> This is a SELinux machine, so I expect some potential interference from the
> security protocols.  I thought I had those bypassed temporarily.  Still no
> luck starting rtig and running the Billards example.
> Can anyone point me to a solution?
> Any help would be truly appreciated.

Hi John,

This is weird, we use CERTI on Ubuntu, Fedora 11-->14 & XP as well.
Concerning SELinux, I don't know on our systems SELinux is disabled (totally).

Does the "certi::NetworkError" occur as soon as rtig is started or
when you launch billard (or any other federate)?

Do you have "http_proxy" or "HTTP_PROXY" env var positionned?
If yes could you try to unset those?

Membre de l'April - « promouvoir et défendre le logiciel libre » -

CERTI-Devel mailing list

I will check my fedora setup when I get home this evening.  I tried my ubuntu machine this morning.
rtig runs ok.   When I try to launch the billard federate I get the following.

address@hidden:~/src/certi/CERTI-3.4.0-Source/test/Billard$ billard -fTest -FTest.fed -n1
CERTI Billard 3.4.0
RTIA:: RTIA has thrown NetworkError exception.
RTIA:: Reason: Proxy connection refused: HTTP/1.0 403 Forbidden
RTIA:: End execution.
UN Socket(RecevoirUN) : : Connection reset by peer
libRTI: exception: NetworkError (read)
Billard::main: RTI exception: RTIinternalError [libRTI: Network Read Error waiting RTI reply].

I have the following for http_proxy

address@hidden:~/src/certi/CERTI-3.4.0-Source/test/Billard$ echo $http_proxy

I hesitate to unset this on my work computer because I am not sure I
understand the consequences.

I now have the billard test running on my XP system (virtual machine running inside vbox).  The menu driven launch does not seem to work for the federates, but if I open command windows and start the federates, it appears to work.  Maybe; I am still studying the result to see if it makes any sense.

CERTI-Devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]