bug-zile
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-zile] Building Zile master head


From: Gary V. Vaughan
Subject: Re: [Bug-zile] Building Zile master head
Date: Sun, 5 Jan 2014 17:58:44 +1300

Hi Reuben,

Thanks again for testing and reporting :)

On Dec 25, 2013, at 3:26 AM, Reuben Thomas <address@hidden> wrote:
> I had one problem: I had to unset LUA_INIT_5_2, as otherwise it didn't like 
> my preloaded libraries. That's a bit odd, considering it's just posix, lfs, 
> rex_pcre and std, but maybe there's still a version-mismatch?

I'm not really familiar with LUA_INIT*, but I followed luaposix's lead, and now 
zmacs and zz both reset LUA_INIT and LUA_INIT_5_2 in the shell-reexec preamble. 
 I also followed suit when calling zlc, and the slingshot Lua scripts from 
local.mk. So, hopefully, even with LUA_INIT_5_2 set in your environment, you'll 
be able to run zmacs without any problems.

> I can see no attempt being made by zmacs to add ${prefix}/share/zmacs to 
> package.path

Right, I concentrated too much on LuaRocks distribution.

I just pushed some patches to re-enable the `./configure; make; sudo make 
install` mode of distribution, though I have a bit more polishing to do, so I 
believe that is fixed now too.

Cheers,
-- 
Gary V. Vaughan (gary AT gnu DOT org)

Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail


reply via email to

[Prev in Thread] Current Thread [Next in Thread]