[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-xorriso] issue concatenating split files with -extract and -cpx

From: William Willems
Subject: [Bug-xorriso] issue concatenating split files with -extract and -cpx
Date: Thu, 10 Oct 2019 13:53:47 -0400

Hi Thomas,

I am having trouble using the "-extract" command for files that were automatically split up when creating the ISO using the -split_size option and am wondering if there is a bug.

Here is what I tried as a test. In a directory, I have a subdirectory containing a 1.5MB photo file "input/test.jpg".

1. Run the command to create an ISO file:

xorriso \
  -for_backup \
  -outdev test.iso \
  -joliet on \
  -split_size 100k \
  -map input/test.jpg test.jpg \
  -volid "TESTCONCAT"

2. Run the command to restore the contents

xorriso \
  -indev test.iso  \
  -osirrox on \
  -extract "/" restore

The "-extract" command completes but it restores a directory containing the file parts. I expected the photo file to be restored instead of having a directory containing the file parts.

Then I tried the "-cpx" command:

xorriso \
  -indev test.iso  \
  -osirrox on \
  -cpx test.jpg restore

The "-cpx" command gives an error "FAILURE : -cpx: May not copy directory '/test.jpg'". I did not expect that error because the contents of the directory at the iso_rr_path all follow the naming convention for a split file. Using the error as a clue, I have been able to work around the error by adding the "-split_size" option to the "-cpx" command and the same fix works for the "-extract" command.

The command that joins and restores the file using "-extract" as I expect is:

xorriso \
  -split_size 1 \
  -indev test.iso  \
  -osirrox on \
  -extract "/" restore 

Note that the split size does not matter as long as it is greater than 0 since the file naming convention describes the size of the parts. So my question is, am I using the "-extract" command correctly? Or is there a bug because the directory is only being correctly identified as containing a split file when I include the "-split_size" option? I am using xorriso version 1.5.0.

Thank you for your help,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]