[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-xorriso] bug with handling symbolic links?

From: Joerg Meyer
Subject: [Bug-xorriso] bug with handling symbolic links?
Date: Mon, 16 Feb 2015 09:09:40 +0100

Dear xorriso developers,

First of all I would like to thank you for all your work on this great project!
Over the weekend, I have worked myself into using xorriso for making backups of 
(incremental) BTRFS snapshots and I have to say that I am really impressed!

The only surprise that I have encountered was when it came to the "ca-certs" 
symbolic links in the attached tarball (hoping that the few kB go through the 
mailing list).
With all -compliance options that I tried (old_rr, new_rr) xorriso-1.3.8 
produces an image that causes numerous
        rock: corrupted directory entry. extent=XXX, offset=XXXX, size=XXX
complaints under linux-3.18.8, and 
        "BAD RRVERSION(??)"
with isoinfo. I have attached the corresponding image together with one 
generate with genisoimage-1.1.11 from cdrkit,
which does not show the above problems. So I suppose it cannot be any general 
"spec violation" of some of the symbolic links?
Although having searched this mailing (or libburn-hackers) list for anything 
related and relevant
I still hope I haven't overlooked anything obvious here and apologize if I did.

Thanks in advance for any hints!

Best wishes,
Jörg Meyer

P.S. I did not have a non-BTRFS at hand, so I cannot say (yet) wether that 
makes a difference

Attachment: certs.genisoimage-1.1.11.iso.gz
Description: GNU Zip compressed data

Attachment: certs.xorriso-1.3.8.iso.gz
Description: GNU Zip compressed data

Attachment: certs.tgz
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]