[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-XBoard] xboard polyglot error...solved

From: Srdja Matovic
Subject: Re: [Bug-XBoard] xboard polyglot error...solved
Date: Sun, 15 May 2016 10:28:46 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.7.2

I took a look into the debug file and found that i messed up the polyglot directory, i mixed up the xboard params "-polyglotBook" and "-polyglotDir"....it works fine again :)

from xboard.debug:
StartChildProcess (dir="/home/srdja/Projects/books/book.bin") polyglot -noini -ec "/home/srdja/Projects/chess/bin/stockfish7" -ed "." -uci NalimovCache=4

On 15.05.2016 09:54, Srdja Matovic wrote:
Recently my xboard on Ubuntu Linux 14.04 throws an error when starting an UCI engine via polyglot.

Tried version 4.7.3 from repository and 4.8.0 self compile, testwise removed .xboardrc and xboard.conf and reinstalled, no luck.

xboard: Error: first chess program (polyglot -noini -ec "/home/srdja/Projects/chess/bin/stockfish7" -ed "/home/srdja/Projects/chess/bin/" -uci NalimovCache=4) exited unexpectedly

When starting polyglot itself, it looks alright...

polyglot -noini -ec "/home/srdja/Projects/chess/bin/stockfish7" -ed "/home/srdja/Projects/chess/bin/" -uci NalimovCache=4,PolyGlot 1.4.67b by Fabien Letouzey.
id name Stockfish 7 64
id author T. Romstad, M. Costalba, J. Kiiski, G. Linscott
option name Write Debug Log type check default false

I surely installed some updates recently, not sure which could have such an effect...any suggestions?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]