[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-XBoard] Some bugs while compiling on OS X 10.10.5

From: Joshua Pettus
Subject: Re: [Bug-XBoard] Some bugs while compiling on OS X 10.10.5
Date: Thu, 10 Dec 2015 23:57:58 -0500

For the record,  the gtk2 mac integration library, and our code that makes use of it,  Is completely centered around an OSX app bundle deployment.   Macports is like a unix style repository for OSX, and anything installed by it would be a classic unix style installation.  Therefor, in this situation, our OSX integration code is completely useless.  Which is fine. Anyone installing via macports is probably looking for a classic unix experience anyway. (Someone like Bob Hyartt for instance who probably doesn’t care for what Apple has to offer anyway XD).


On Dec 10, 2015, at 11:48 PM, Joshua Pettus <address@hidden> wrote:

On Dec 10, 2015, at 2:45 PM, address@hidden wrote:

Op Do, 10 december, 2015 2:58 am schreef global667:

I got many, many warnings, while building the sources under OS X 10.10.5
with clang (see attachment), but it works.

If I run ./xboard with GTK, I got an warning.

$ ./xboard
No default pieces installed!
Select your own using ‚-pieceImageDirectory'.

Sounds like you forgot to do "sudo make install”…
The warnings are normal and nothing  to worry about.

Yeah,  Xboard looks for it’s resources in the standard unix directories and needs the "sudo make install" to set everything up correctly.  Idk if the installation script takes in to account the “prefix" parameter which would be needed for many macports installs?  (For the record, macports defaults to a prefix of /opt/local and any app needs to be installed in there)  Such directories really isn’t ideal for mass osx deployment which is why we went through the trouble of bundling xboard in an app bundle, (taking advantage of the quartz version of GTK2, the GTK2 mac integration library, and a few extra lines of code on our part)


with Xaw I got:

$ ./xboard
Error: Can’t open display:

This sounds like an internal Xaw error. The string "open display" does not
occur in the source anywhere.

Don't bother too much with Xaw. The future is GTK.

Well even for the standard GTK2 on OSX, a working X11 server is important.
It sounds like you have a problem with your X11 server.  I assume you have Xquartz.app installed or at least the macports x11 server port?  I know Xquartz.app works fine, but I haven’t ever tried the x11 port.  Might need some extra configuration.. do other x11 based apps work?  Inkscape comes to mind.

I assume you will be making the port for the X11 version of GTK2?  That’s generally what other GTK based macports use, and is still the default gtk2 install.

If you need any help, let me know.  I believe a working up-to-date macports port, as another option besides the app bundle, is very desirable.

Best Regards,

By the way: I have become the maintainer of the sources of Xboard on
Macport if it is okayfor you. I will put it to 4.8 and perhaps add gtk

OK, great. I am a Mac-ignorant, but please note that the sources can be
built for OS X through the Gtkosx library. Joshua Pettus can tell you more
about that.



Bug-XBoard mailing list

Bug-XBoard mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]