[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-XBoard] xboard: Failed to start first chess program gnuchessx o

From: Ketan Shah
Subject: Re: [Bug-XBoard] xboard: Failed to start first chess program gnuchessx on localhost: gnuchessx: No such file or directory
Date: Wed, 11 Mar 2009 12:27:54 +0530
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113


If you are using GNU Chess and you see this problem as soon as it starts up, most likely GNU Chess is exiting with an error message. If you see the message "NO LANGFILE", it m
eans that you did not install GNU Chess correctly, and it is unable to find the file gnuchess.lang. Make sure that you defined LIBDIR in the gnuchess Makefile, and that gnuche
ss.lang is in that directory. If gnuchess.lang is not there, you probably didn't type "make install" in the gnuchess src directory; you must do this to install gnuchess.lang (
and the gnuchess book). If you defined LIBDIR to something that is not an absolute pathname (that is, to something that does not start with a "/"), GNU Chess will work only if
 you run it from the GNU Chess "src" directory where you built it

I was only using make but just to cross check  I  tried make install-sh   it says nothing to for install-sh .
Please can you tell me from where i can download GNU chess 5  .

Probably GNU chess it is not  installed in our system  ( Please  can you tell me path for the same i will double check  ?? )
Thanks !!


Tim Mann wrote:
You would probably be better off using GNU Chess 5, not GNU Chess 4,
but if you want to use GNU Chess 4, I think the langfile error is
covered in the FAQ too.  See question [C.19], second paragraph.

By the way, I am puzzled why you are compiling xboard 4.2.7 and GNU
Chess from source for Linux.  Most Linux distributions include these
programs in packages.

On Wed, 11 Mar 2009 10:20:10 +0530, Ketan Shah <address@hidden> wrote:
  Thanks for the info ..
  I have tried to install gnuchess-4.0.pl80
  so i was facing one issue  attached file which describes the cmds and its
output (log.txt)

dspcomN.o(.text+0x17e5): In function `ElapsedTime':
: undefined reference to `errno'
collect2: ld returned 1 exit status
make: *** [gnuchess] Error 1

  so to avoid above problem i  have modfied gnuan.c and dspcom.c as errno
are used in fprintf only ..

==org code ==
   fprintf (stderr,    "You probably have a non-ANSI <ioctl.h>; see README.
%d %d %x\n",  i, errno, FIONREAD);
== modfied code
   fprintf (stderr,    "You probably have a non-ANSI <ioctl.h>; see README.
%d %x\n",  i,  FIONREAD);

 and recompiled every c file and put gnuchess in my PATH variable
 My PATH variable has :

  Now whne i am doing xboard facing following issue ..
xboard: Failed to start first chess program gnuchessx on localhost: NO
LANGFILE (file gnuchess.lang not found)

i have seen gnuchess.lang  is present at $HOME/chess/gnuchess-4.0.pl80/misc
still i am facing above issue .. please can you help on the same ?

Thanks !!


On Tue, Mar 10, 2009 at 10:20 PM, Tim Mann <address@hidden> wrote:

See http://tim-mann.org/xboard/FAQ.html#[C.22] in the FAQ.

On Mon, 9 Mar 2009 10:06:30 +0530, Ketan Shah <address@hidden> wrote:

  I have donwloaded the xboard4.2.7 from
  And i have run  the  folliwing cmd on linux  terminal but i  am not
to run the xboard geting the error .

xboard: Failed to start first chess program gnuchessx on localhost:
gnuchessx: No such file or directory

 Please can anyboy help on this ???

 Attaching below with cmd and its output from linux Termina ...

1) #uname -a
   Linux bdbtplindt0667 2.6.9-67.0.4.EL #1 Fri Jan 18 04:50:00 EST 2008
i686 i386 GNU/Linux

2) #./configure
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for library containing strerror... none required
checking for a BSD-compatible install... /usr/bin/install -c
checking for lex... lex
checking for flex... (cached) lex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for remsh... no
checking for rsh... rsh
checking for nroff... nroff -man
checking for awk... /usr/bin/awk
checking for perl... /usr/bin/perl
checking for egrep... grep -E
checking for ANSI C header files... yes
checking whether time.h and sys/time.h may both be included... yes
checking for sys/wait.h that is POSIX.1 compatible... yes
checking for dirent.h that defines DIR... yes
checking for library containing opendir... none required
checking return type of signal handlers... void
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking stropts.h usability... yes
checking stropts.h presence... yes
checking for stropts.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking for string.h... (cached) yes
checking for unistd.h... (cached) yes
checking sys/systeminfo.h usability... no
checking sys/systeminfo.h presence... no
checking for sys/systeminfo.h... no
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking sys/socket.h usability... yes
checking sys/socket.h presence... yes
checking for sys/socket.h... yes
checking stddef.h usability... yes
checking stddef.h presence... yes
checking for stddef.h... yes
checking for _getpty... no
checking for grantpt... yes
checking for setitimer... yes
checking for usleep... yes
checking for gettimeofday... yes
checking for random... yes
checking for gethostname... yes
checking for setlocale... yes
checking for getpseudotty in -lseq... no
checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking X11/xpm.h usability... yes
checking X11/xpm.h presence... yes
checking for X11/xpm.h... yes
checking for XpmReadFileToPixmap in -lXpm... yes
checking whether ptys or pipes should be used... pipes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating cmail
config.status: creating xboard.texinfo
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing default commands

3) make
 gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c parser.c
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c xboard.c
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c backend.c
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c moves.c
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c childio.c
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c gamelist.c
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c lists.c
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c pgntags.c
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c xgamelist.c
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c xedittags.c
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c xhistory.c
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c zippy.c
gcc -o xboard  parser.o xboard.o backend.o moves.o childio.o gamelist.o
lists.o pgntags.o xgamelist.o xedittags.o xhistory.o zippy.o
-L/usr/X11R6/lib -lXaw  -lXmu  -lXt -lXext -lXpm  -lSM -lICE -lX11   -lm
gcc -DHAVE_CONFIG_H -I. -I.  -I/usr/X11R6/include  -I/usr/X11R6/include
-DINFODIR=\"/usr/local/share/info\" -c zic2xpm.c
gcc -o zic2xpm zic2xpm.o

4) ./xboard -debug

recognized 'normal' (-1) as variant normal
resolved -*-helvetica-bold-r-normal--*-*-*-*-*-*-*-* at pixel size 34
  to -adobe-helvetica-bold-r-normal--34-240-100-100-p-182-iso8859-1
resolved -*-helvetica-bold-r-normal--*-*-*-*-*-*-*-* at pixel size 14
  to -adobe-helvetica-bold-r-normal--14-140-75-75-p-82-iso8859-1
resolved -*-helvetica-medium-r-normal--*-*-*-*-*-*-*-* at pixel size 14
  to -adobe-helvetica-medium-r-normal--14-140-75-75-p-77-iso8859-1
xboard 4.2.7 + gnuchessx
Reset(1, 0) from gameMode 0
recognized 'normal' (-1) as variant normal
GameEnds(0, (null), 2)
StartChildProcess (dir="") gnuchessx
367 >first : xboard
protover 2
374 <first : gnuchessx: No such file or directory
xboard: Failed to start first chess program gnuchessx on localhost:
gnuchessx: No such file or directory

GameEnds(0, (null), 2)
2908 >first : force
2908 >first : quit

  Thanks !!


Tim Mann  address@hidden  http://tim-mann.org/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]