[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: About the Makefile target "check"

From: Przemysław Wojnowski
Subject: Re: About the Makefile target "check"
Date: Sun, 1 Nov 2015 12:17:13 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.3.0

Hello everybody,

Sorry to resurrect the dead [1], but the proposal IMHO have been dismissed too
early, without proper consideration.

I agree that having both "test" and "check" is unnecessary choice. But I also think that "check" is less intuitive than "test" for running tests and should be dismissed.

What I mean by intuitive is that many other build tools [2], which have
standard tasks, use the name "test" for exactly this purpose. So, many programmers can immediately reuse their knowledge to such simple tasks as running tests, which makes it easier (at least a bit) to join a project.
Reuse of their knowledge _is_ better solution that making them to read endless

The argument that "[check] is well known by the community" is negligible,
because the community use also other build tools and very well know "test" too.
Moreover, "test" is already known (by most of the programming world, as you can
see below) to those that are outside the community and maybe someday would like
to join.

Kindest Regards,

1. http://lists.gnu.org/archive/html/bug-standards/2015-10/msg00000.html

2. Maven (http://maven.apache.org/surefire/maven-surefire-plugin/usage.html)
Gradle (https://docs.gradle.org/current/userguide/java_plugin.html#sec:java_test)
   Leiningen (https://github.com/technomancy/leiningen)
   NPM (https://docs.npmjs.com/cli/test)
   SBT (http://www.scala-sbt.org/0.12.4/docs/Detailed-Topics/Testing.html)
   Raco (http://docs.racket-lang.org/raco/test.html)
Python (python -m unittest discover <test_directory>) - not exactly test, bust still very close

reply via email to

[Prev in Thread] Current Thread [Next in Thread]