[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Display difference between ncurses version 5.7 and version

From: Thomas Dickey
Subject: Re: Display difference between ncurses version 5.7 and version
Date: Tue, 18 Jul 2017 20:49:24 -0400
User-agent: Mutt/1.5.21 (2010-09-15)

On Tue, Jul 18, 2017 at 10:16:13AM -0700, Rich Burridge wrote:
> Hi,
> I'm getting a display problem with the latest version of ncurses.
> This is on Solaris.
> I've attached a small self-contained Python script that replicates
> the problem. This is taken from a much larger Python application.
> (I note that I do not see the problem when I run the script on my
> Ubuntu LTS 16.04 system.)
> I've also attached a screen-shot of the difference in behaviour that
> I'm seeing. The top window comes from running on a system where ncurses
> version 5.7 is installed. That's the desired result.
> When I run the script on a system with ncurses version,
> I only get cyan characters for the spaces in the text string, not for
> the rest of the text.

fwiw, I just tested with current ncurses on my Debian7 machine,
and it works as expected, and I compiled ncurses 5.7 to run the
same test - still works.
> What needs to be done to get the desired behaviour in this latter case?

I'd start by checking the terminal description: if you're using anything
from Solaris itself, that's a problem.  infocmp would show where it's
read from (and interesting things like "bce" which are likely problems).

I have a to-do note dealing with "xterm+256color" on Solaris (it's
completely wrong).

Thomas E. Dickey <address@hidden>

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]