[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: multi-line field issues

From: tjareson
Subject: Re: multi-line field issues
Date: Thu, 30 Aug 2012 21:20:04 -0300
User-agent: Mozilla/5.0 (X11; Linux i686; rv:14.0) Gecko/20120713 Thunderbird/14.0

Unfortunately things were not as easy as I first thought:

Since I upgraded from ncurses 5.7 to 5.9 the multi line field issue is solved, but all off a sudden German Umlaut (äöü etc.) are not working anymore when using form_driver, which worked before with exactly the same source code. Of course, locale settings didn't change. Also setlocale-settings command in the source is not change (de_DE.UTF-8 as before).

Now everytime I press an Umlaut key I get 3-4 "weird" chars instead of that one sign displayed. ncursesw / formw etc. is linked like it was before. Also the make was done with wide-character support. Nothing changed accept the version.

Was there any major change regarding utf8 / locale support since 5.7? Honestly I'm a little bit lost. The funny thing is: data I read from the database get displayed properly in forms, only entering umlauts with the keyboard is not working anymore.

What might be worth to mention: I'm using wgetch() to get keyboard inputs. (as before) If I'm using wget_wch() instead, I only get an empty character shown by form_driver.

Any ideas, hints?

kind regards

Am 30.08.2012 18:00, schrieb tjareson:

Am 30.08.2012 07:13, schrieb Thomas Dickey:
On Wed, Aug 29, 2012 at 09:34:01PM +0000, Tjareson wrote:
Sentinel <sentinel.2001 <at> gmx.com> writes:

I have been studying some apps that
ncurses and found that none of them use multiline. Most just invoke vim or
write their own.

Thus, at the time of set_field_buffer and field_buffer if data
transformation can be done so a file can be read and set in, and then
saved out, and it remains as is, it would be great.
I'm currently implementing an application using ncurses and also tried to use a
multiline field to edit longer texts.

Is there any solution to that issue? I have the problem that I can edit properly in a multiline field, I even can load a TEXT-field from MYSQL into it and it
gets displayed properly (also with new lines etc.)

But I was never able to get more back from a multiline field that the first row.

Someone wrote there is an application-wise workaround for that. Any ideas what
  to do solve that issue?
The example "demo_forms" seems to work - I'm not sure what issue you're
reporting.  (A short sample program might help).

Thanks a lot for quick reply. I'm sorry but I had to find out that this Ubuntu here was running with an ncurses version 5.7 for whatever reason. After updating everything, all is working fine. (Could have checked that before...) And: ncurses is great. Programming text interfaces is so much easier with it. :-) Thanks for maintaining all this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]