[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-mit-scheme] [bugs #10458] Can't create threads from --eval command-

From: anonymous
Subject: [Bug-mit-scheme] [bugs #10458] Can't create threads from --eval command-line option.
Date: Tue, 21 Sep 2004 02:26:44 -0400
User-agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5 (KHTML, like Gecko) Safari/125.9

This mail is an automated notification from the bugs tracker
 of the project: MIT/GNU Scheme.

[bugs #10458] Full Item Snapshot:

URL: <http://savannah.gnu.org/bugs/?func=detailitem&item_id=10458>
Project: MIT/GNU Scheme
Submitted by: 0
On: Tue 09/21/2004 at 02:14

Category:  runtime
Severity:  5 - Average
Item Group:  Suboptimal behavior
Resolution:  None
Privacy:  Public
Assigned to:  None
Status:  Open

Summary:  Can't create threads from --eval command-line option.

Original Submission:  I've written a server that I would like to start 
automatically when MIT Scheme starts.  I'm trying to automate this using the 
--eval command-line option, but the thread that the server starts seems to exit 
right away -- or at least to get no time slices.  The same thread, started from 
the REPL, works just fine.

I've tried a simpler example that just starts an infinite output loop, with the 
same results.  See the attached file for an example.  I've also tried 
experimenting with the first argument to `create-thread' and with removing the 
use of `detach-thread,' but without success.

I'm trying to figure out why --eval has this behavior, but haven't had any 
success.  I'd be grateful for any hints.  I'll keep working on this in any case.


For detailed info, follow this link:

  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]