[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Regression on Cygwin: Problems with parallel make in 4.4

From: Ken Brown
Subject: Re: Regression on Cygwin: Problems with parallel make in 4.4
Date: Wed, 15 Feb 2023 13:57:53 -0500
User-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:102.0) Gecko/20100101 Thunderbird/102.7.2

On 2/15/2023 1:34 PM, Bruno Haible wrote:
Paul Smith wrote:
And possibly also on GNU/Hurd. Cf.

I may be misremembering but I thought that you had tried forcing the
pipe jobserver option on GNU/Hurd and it didn't help.

This must be a misunderstanding. I never said that. I don't even know
how to do this, within the framework of GNU make's test suite.

All I said was, comparing the Cygwin failures with the GNU/Hurd failures [1]:
   "In all these failures, where we see an error message "Leftover temporary
    files" in GNU/Hurd, we see "Device or resource busy" in Cygwin."


[1] https://lists.gnu.org/archive/html/bug-make/2023-01/msg00134.html

One thing to keep in mind here is that your tests on Cygwin were done on Cygwin 2.9.0, in which FIFOs were very poorly supported. For example, a FIFO couldn't have multiple readers or writers. If GNU/Hurd has similar limitations, that could explain the similar test results.

Cygwin's FIFO implementation was completely rewritten starting with 3.0, and it now supports multiple readers and writers. So the issue with current Cygwin is more likely a bug in Cygwin and/or make.

Marco, did you by any chance run the test suite when you built make for Cygwin? It would by interesting to know what test failures there are with Cygwin 3.4.6.


P.S. Here's a footnote about the failures I'm seeing.  I cited

  https://tug.org/pipermail/tlbuild/2023q1/005290.html ,

in which I reported problems with the build of TeX Live. I said I had a hang in 'make -j13 world'. This was an oversimplification. What really happens is that the hang occurs when I run the 'Build' script provided by the TeX Live sources. This is a shell script that runs make in a further sub-shell. If I simply run 'make -j13 world' without using the Build script, it doesn't hang. I don't know if this provides any clue as to where the problem is.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]