[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #15919] Make-3.81 rc1 hangs with -j 2 but not with -j 1

From: Paul D. Smith
Subject: [bug #15919] Make-3.81 rc1 hangs with -j 2 but not with -j 1
Date: Fri, 05 Jun 2009 14:24:08 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/2009042513 Ubuntu/8.04 (hardy) Firefox/3.0.10

Follow-up Comment #29, bug #15919 (project make):

I took a copy of glibc 2.9 and tried building it with -j10 on my uniprocessor
and on my dual core (actually single hyperthreading CPU) and it worked fine.

But when I took it to a 4-way hyperthreading (8 core) system and ran with
-j10 I did see some bad behavior: not hangs though.  Instead it seemed the
same recipe was being invoked >1 time which eventually caused the build system
to fail, because at the end of the recipe there's a job that removes a file. 
If the multiple recipes run in the "right" way then one of the instances
removes that file before the next one gets a chance to use it.

I'll look at this.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]