[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug-mailutils] argument parsing

From: djh
Subject: [bug-mailutils] argument parsing
Date: Fri, 10 Mar 2006 17:47:39 +0900
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.11) Gecko/20050728

I tracked what I think is a bug in mh "send" program's argument parsing. This might be common for other mh programs as well, but I haven't looked.

Here is a description of the problem:

Invoking Mailutils send command direct from the command line with the exact same arguments that mh-e invokes it with, and invoking it without quoated arguments.

In mh-comp.el's  mh-send-letter function definition, MH send is called like:

(mh-exec-cmd-daemon mh-send-prog nil "-nodraftfolder" "-noverbose"
                               mh-send-args file-name)

All arguments have double quotes around them. The one with double quotes, gave me the same error message as when invoked from within mh-e.

$ send "-nodraftfolder" "-noverbose" "-msgid " "/home/henman/mail/drafts/1894"
send: invalid option -- m

error here with $? == 64.

$ send -nodraftfolder -noverbose -msgid /home/henman/mail/drafts/1894
success here with $? == 0

Help. I tried going through send, but am not familiar with the argument parsing at all.

I think that the programs should be able to handle quoted arguments.

Please look into it.

  Darel Henman

reply via email to

[Prev in Thread] Current Thread [Next in Thread]