[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Oops

From: Jakob 'sparky' Kaivo
Subject: Re: Oops
Date: 08 Jun 2001 19:07:16 -0700
User-agent: Gnus/5.0808 (Gnus v5.8.8) Emacs/21.0.95

"Alain Magloire" <address@hidden> writes:

> It seems that you can not write
> back to the mailbox.  It this is a test application
> maybe you open the mailbox MU_STREAM_READ only ?
> or the mailbox is permission read only, or the
> mail is not sgid mail etc ... or a bug in the library
> send me you test case or how to reproduce I will
> track back.

Using mail from a fresh mailutils build (sync'd a few hours ago):

address@hidden:~/test$ ~/mailutils/mail/mail -n -f`pwd`/mailbox
mail (mailutils) 0.0.9, Copyright (C) 2001 Free Software Foundation,
mail comes with ABSOLUTELY NO WARRANTY; for details type
'warranty'. This is free software, and you are welcome to
redistribute it under certain conditions; type 'copying'
for details.
> 1 Mail Delivery Subsystem Postmaster notify: Service unavailable
  2 Mail Delivery Subsystem Postmaster notify: Cannot send message
within 5
  3 Mail Delivery Subsystem Postmaster notify: Cannot send message
within 5
  4 root <address@hidden mirror update
  5 root <address@hidden mirror update
?d *
Error expunging:833: Permission denied

address@hidden:~/test$ ls -l mailbox
-rw-r--r--    1 jkaivo   jkaivo      18069 Jun  8 18:54 mailbox
address@hidden:~/test$ rm mailbox
address@hidden:~/test$ ls -l mailbox
ls: mailbox: No such file or directory

I don't think mail needs to be setgid mail, I have all permissions to
this file. Even as root, the same error results. Nothing special about
the mailbox, I get the same result on all mbox files I've tried. POP3
and IMAP4 backends work excellently, though.

-- sparky

reply via email to

[Prev in Thread] Current Thread [Next in Thread]