[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: freadseek.c not ported to GNU when building M4

From: Mohammad Akhlaghi
Subject: Re: freadseek.c not ported to GNU when building M4
Date: Sun, 7 Apr 2019 15:21:11 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.6.1

Hi Bruno,

On 4/7/19 11:38 AM, Bruno Haible wrote:
Thanks for the report. It has already been reported on the bug-m4 list:


m4 uses gnulib as a submodule, which means that an explicit action is needed
by the m4 maintainers to move it past 2018-03-05 (which is when the fix was
added to gnulib).

$ git clone git://git.savannah.gnu.org/m4.git
$ cd m4
$ ./bootstrap --copy --gnulib-srcdir=/path/to/gnulib
$ ./configure
$ make

Probably you'll want to use the 'branch-1.4' branch, instead of the 'master'

Thanks, I tried `branch-1.4', but the same error came up. I then tried M4 versions 1.4.16 and 1.4.12, but they also gave similar `gets' errors.

I noticed that Arch Linux's package manager has the necessary corrections as a patch:

After applying them, M4 was successfully built.

I look forward to the necessary corrections applied directly in the M4 source.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]